Pkg problems - Impossible to update packages and to install some of them


#1

Dear Julia users,

I am so desperate, since last Friday I have been having troubles with almost all the packages that I wanted to install.

First of all I was triying to update my packages and I get the following error.


Pkg.update()
INFO: Updating METADATA...
INFO: Updating BinaryProvider master...
INFO: Computing changes...
ERROR: resolve is unable to satisfy package requirements.
  The problem was detected when trying to find a feasible version
  for package Compat.
  However, this only means that package Compat is involved in an
  unsatisfiable or difficult dependency relation, and the root of
  the problem may be elsewhere

Secondly, I was trying to install the Gurobi Solver and I got:

Pkg.add("Gurobi")
ERROR: resolve is unable to satisfy package requirements.
  The problem was detected when trying to find a feasible version
  for package Compat.
  However, this only means that package Compat is involved in an
  unsatisfiable or difficult dependency relation, and the root of
  the problem may be elsewhere.

resolve(::Dict{String,Base.Pkg.Types.VersionSet}, ::Dict{String,Dict{VersionNumber,Base.Pkg.Types.Av
ailable}}) at .\pkg\resolve.jl:48
resolve(::Dict{String,Base.Pkg.Types.VersionSet}, ::Dict{String,Dict{VersionNumber,Base.Pkg.Types.Av
ailable}}, ::Dict{String,Tuple{VersionNumber,Bool}}, ::Dict{String,Base.Pkg.Types.Fixed}, ::Dict{Str
ing,VersionNumber}, ::Set{String}) at .\pkg\entry.jl:499
resolve(::Dict{String,Base.Pkg.Types.VersionSet}, ::Dict{String,Dict{VersionNumber,Base.Pkg.Types.Av
ailable}}, ::Dict{String,Tuple{VersionNumber,Bool}}, ::Dict{String,Base.Pkg.Types.Fixed}) at .\pkg\e
ntry.jl:479
edit(::Function, ::String, ::Base.Pkg.Types.VersionSet, ::Vararg{Base.Pkg.Types.VersionSet,N} where
N) at .\pkg\entry.jl:30
(::Base.Pkg.Entry.##1#3{String,Base.Pkg.Types.VersionSet})() at .\task.jl:335

Thirdly with the Juniper Package:

Pkg.add("Juniper")
ERROR: Unsatisfiable requirements detected for package MathProgBase:
├─version range [0.7.0,0.7.0+) set by an explicit requirement
└─version range [0.6.0,0.7.0-) required by package Juniper, whose allowed version range is [0.0.0-,∞
):
  └─version range [0.0.0-,∞) set by an explicit requirement
The intersection of the requirements is empty.
filter_versions(::Dict{String,Base.Pkg.Types.VersionSet}, ::Dict{String,Dict{VersionNumber,Base.Pkg.
Types.Available}}, ::Dict{AbstractString,Base.Pkg.Types.ResolveBacktraceItem}) at .\pkg\query.jl:299

prune_versions(::Dict{String,Base.Pkg.Types.VersionSet}, ::Dict{String,Dict{VersionNumber,Base.Pkg.T
ypes.Available}}, ::Dict{AbstractString,Base.Pkg.Types.ResolveBacktraceItem}) at .\pkg\query.jl:328
prune_dependencies(::Dict{String,Base.Pkg.Types.VersionSet}, ::Dict{String,Dict{VersionNumber,Base.P
kg.Types.Available}}, ::Dict{AbstractString,Base.Pkg.Types.ResolveBacktraceItem}) at .\pkg\query.jl:
546
resolve(::Dict{String,Base.Pkg.Types.VersionSet}, ::Dict{String,Dict{VersionNumber,Base.Pkg.Types.Av
ailable}}, ::Dict{String,Tuple{VersionNumber,Bool}}, ::Dict{String,Base.Pkg.Types.Fixed}, ::Dict{Str
ing,VersionNumber}, ::Set{String}) at .\pkg\entry.jl:498
resolve(::Dict{String,Base.Pkg.Types.VersionSet}, ::Dict{String,Dict{VersionNumber,Base.Pkg.Types.Av
ailable}}, ::Dict{String,Tuple{VersionNumber,Bool}}, ::Dict{String,Base.Pkg.Types.Fixed}) at .\pkg\e
ntry.jl:479
edit(::Function, ::String, ::Base.Pkg.Types.VersionSet, ::Vararg{Base.Pkg.Types.VersionSet,N} where
N) at .\pkg\entry.jl:30
(::Base.Pkg.Entry.##1#3{String,Base.Pkg.Types.VersionSet})() at .\task.jl:335

And also when I am triying to build the Ipopt package I get:


[ BUILD ERRORS ]=======================
WARNING: Ipopt had build errors.

 - packages with build errors remain installed in /home/user/.julia/v6.0
 - build the package(s) and all dependencies with `Pkg.build("Ipopt")`
 - build a single package by running its `deps/build.jl` script

================================
INFO: Package database updated
INFO: METADATA is out-of-date — you may not have the latest version of Ipopt

Someone knows what is the problem? It is insane, I have never had so much troubles for installing packages in any environment.


Error with NullableArrays when trying to install or remove packages or run Pkg.update()
#2
/home/jeff/.julia/v0.3

Are you using version 0.3?


#3

No, I am using v6.2.2 mkl. It was a mistake, I had it in my wallpaper a copy of another github error.


#4

This is JuliaPro, right? A number of people have been having package update issues with it lately, because JuliaPro has a pretty restricted set of required packages and versions. You might want to try downloading the plain command line Julia from https://julialang.org/downloads/ to see if that resolves the package issues.


#5

See also NullableArrays: resolve is unable to satisfy package requirements


#6

Fix for this issue can be found here