Pkg installation error

package

#1

I’ve been having the following error with installing NLopt, and have been advised this is an issue with julia rather than the package:


#2

I’m pretty sure this is a github problem, not a Julia issue, since we also had problems with a non-Julia project that was building NLOpt today. Can you try again?


#3

Tried again - same thing.


#4

Any suggestions for how to solve? I’m still not having any joy.


#5

I’m pretty sure the github issues were resolved, so I don’t know why this would still be happening.

Did you try Pkg.update()?


#6

On Julia 0.5.1. it is still regularly occurring, in my case around either imaging or DifferentialEquations. I believe some additional Pkg resolver bug fixes need to be backported as part of a Julia 0.5.2 release.


#7

@goedman do you mean specifically NLOpt? I’ve seen the other issues about “no feasible version” with the package resolver, but I think this issue is different (it’s specifically about not being able to find the NLopt github repo).


#8

@rdeits , apologies, yes, this seems a different problem.