package installation problem - Pkg.build("HDF5")

question

#1

Hello everyone,

Yesterday, I have installed Julia on my macOS High Sierra, version 10.13.6 (the latest).
When I ran the command:

Pkg.build(“HDF5”)

I get the error message:

julia> Pkg.build(“HDF5”)

Building LibCURL ─→ ~/.julia/packages/LibCURL/OoXMv/deps/build.log

Building WinRPM ──→ ~/.julia/packages/WinRPM/Y9QdZ/deps/build.log

Building Homebrew → ~/.julia/packages/Homebrew/l8kUw/deps/build.log

┌ Error: Error building Homebrew:

│ Already up-to-date.

│ Error: gcc@5: Unsupported special dependency :maximum_macos

│ ERROR: LoadError: ArgumentError: brew info failed for [“gcc”]!

│ Stacktrace:

│ [1] json(::Array{String,1}) at /Users/cortesao/.julia/packages/Homebrew/l8kUw/src/API.jl:192

│ [2] info(::Array{String,1}) at /Users/cortesao/.julia/packages/Homebrew/l8kUw/src/API.jl:229

How can this problem be solved?

Cheers,
Rui


#2

What happens when you type gcc in Terminal?


#3

If I type just gcc it displays:

clang: error: no input files

If I type gcc --version it displays:

Configured with: --prefix=/Applications/Xcode.app/Contents/Developer/usr --with-gxx-include-dir=/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.14.sdk/usr/include/c++/4.2.1

Apple LLVM version 10.0.0 (clang-1000.11.45.2)

Target: x86_64-apple-darwin17.7.0

Thread model: posix

InstalledDir: /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin


#4

Typing gcc would have installed it if not already.


#5

Please first run

Brew install hdf5 before building hdf5


#6

It feels like Julia should somehow be able to do this automatically.


#7

I agree, but it is not possible with the Homebrew package since it maintains its own patched versions of brew packages, which are giving problems with HDF5, due to some incompatibilities; there are issues opened regarding this but there hasn’t been progress on any of them, since most are transitioning to BinaryBuilder solutions, but HDF5 does not support cross-compilation so we cannot use BinaryBuilder yet .