Anyone know status of HDF5 build problems?


#1

Trying to install HDF5.jl, but running into the fact that homebrew keeps trying to build gcc from scratch. This seems to be known in HDF5 (here and here). They pointed to the Homebrew team, but they’ve closed the issue and seem to think it’s fixed (here). But seems like it’s not.

HDF5 (which also underlies JLD as I understand it) is a pretty central package to be uninstallable for almost 2 months now, and I know it’s basically jammed my workflow. Anyone know what’s up with it?

UPDATE: Homebrew team says:

The gcc bottle is not marked as relocatable so we make no guarantees about --force-bottle working. We’d happily review a PR changing the formula in some way so that this doesn’t happen but none of the maintainers are working on this and we don’t just leave issues open no one is working on.

So sounds like it’s up to Julia teams to come up with a new implementation?


HDF and JLD have been unbuildable on macs for months... Not sure anyone is addressing
#2

Just got this working about the same time you posted this.

I think the thing that got me closest to the solution was doing:

brew install hdf5

in the terminal.

And then

Pkg.build("HDF5")

in the REPL


but stuff like this is always hard to remember how to solve?

I think doing stuff like:

brew doctor
brew update

and

softwareupdate --install -a

also helped.

Good luck!


@andreasnoack @denizyuret, are those things you did to get JLD working on macs?


Fixing GCC/Homebrew building issues on macOS?
#3

Thank you @djsegal ! Success!

To clarify @djsegal’s suggestion a little, I:

  • Went to the Homebrew website, downloaded and installed Homebrew normally (i.e. not through Julia)
  • ran brew install hdf5 in the terminal (not in julia)
  • THEN did Pkg.build("HDF5") in julia (0.6.3).

Success!

More generally, though, this still seems like a big general problem for new users – being able to read data and save things seems pretty central to Julia. Surely we can make this install work better?

(Sorry – I know it’s bad form to push for a fix to something open source if you aren’t in a position to do it oneself, but in this case I know NOTHING about gcc or homebrew, so am really not in a position to offer PRs. :frowning: )


Problems to Install JLD, HDF5
#4

Thanks. I managed to install HDF5 and home-brew, but I still having problems to build HDF5 in Julia 0.6.4


#5

Finally, I made it. Instead of Pkg.build(“HDF5”) in Julia after the first two steps you told me to do, I tried again Pkg.add(“HDF5”) and now it’s ok for JULIA0.6.4.
Thanks.


#6

I had the same issue for a while on my Macbook Pro (OSX 10.11.6), but today, I decided to rebuild the whole packages via pkg> build (on Julia v0.7). Then, as before, when HDF5.jl was being built, it first tried to install gcc 8.2.0 via Homebrew.jl as before. It again took a long time (~ 1 hour or so), but somehow it finished today and built both gcc 8.2.0 via Homebrew.jl, and so did HDF5.jl. I have no idea why it worked this time, but not previously though. Previously, compiling gcc 8.2.0 failed. I’m using HDF5 v0.9.3 and Homebrew v0.7.0 (both the official releases, not the current master branches). I’m happier, but puzzled why it didn’t work before.
BTW, building Homebrew.jl itself still fails with the error: unknown option `shallow-since=refs/tags/1.7.1'.