OSX - Julia 1.0 won't start - segmentation fault

Trying to start up Julia 1.0 (from the released binaries) on OSX, and it immediately seg faults:


signal (11): Segmentation fault: 11
in expression starting at no file:0
jl_typemap_entry_assoc_exact at /Users/osx/buildbot/slave/package_osx64/build/src/typemap.c:774
jl_typemap_assoc_exact at /Users/osx/buildbot/slave/package_osx64/build/src/./julia_internal.h:883 [inlined]
jl_lookup_generic_ at /Users/osx/buildbot/slave/package_osx64/build/src/gf.c:2133
jl_apply_generic at /Users/osx/buildbot/slave/package_osx64/build/src/gf.c:2179
#print_to_string#330 at ./strings/io.jl:124
print_to_string at ./strings/io.jl:112 [inlined]
string at ./strings/io.jl:143 [inlined]
__init__ at ./sysinfo.jl:114
jl_apply at /Users/osx/buildbot/slave/package_osx64/build/src/./julia.h:1536 [inlined]
jl_module_run_initializer at /Users/osx/buildbot/slave/package_osx64/build/src/toplevel.c:90
_julia_init at /Users/osx/buildbot/slave/package_osx64/build/src/init.c:811
julia_init__threading at /Users/osx/buildbot/slave/package_osx64/build/src/task.c:302
main at /Applications/Julia-1.0.app/Contents/Resources/julia/bin/julia (unknown line)
Allocations: 2519 (Pool: 2511; Big: 8); GC: 0

[Process completed]

Any ideas?

That’s scary. Corrupted download maybe?

I tried to download again just a few min ago, same problem.

Do you have any sort of startup file that would try to load some code or anything else unusual about your environment? We did test the OS X release binaries on a couple of Macs before putting them up on the website, so I don’t think they’re broken for everybody, but would be good to figure out what triggers this.

I think I fixed it -> in my bash_profile I had this:

export PATH="/Applications/Julia-0.7.app/Contents/Resources/julia/bin:$PATH"
export JULIA_BINDIR="/Applications/Julia-0.7.app/Contents/Resources/julia/bin"

I commented those out, and now 1.0 starts up fine. I’m wondering if it was setting the JULIA_BINDIR env variable.

Setting that still shouldn’t cause Julia to segfault. Could you file a GitHub issue with as much info about how to reproduce?

1 Like

Thanks cormullion!