Julia osx 0.5 not starting


#1

Just downloaded Julia DMG v0.5 for osx and it is not starting. I get two terminal windows opening but there is only a unix prompt, no julia REPL. I notice the Julia menu appears briefly and then disappears. Have tried 0.5 and 0.6 - same problem.


#2

What version of OSX?


#3

macOS Sierra Version 10.12.2 (16C67)


#4

Try changing dir into the .app bundle directory from a terminal, and running Contents/MacOS/Julia. You might get more descriptive messages.


#5

Just getting the following message.

2016-12-17 06:21:54.198 Julia[2053:59684] App did finish launching


#6

Created a new user account on the same machine and Julia runs perfectly, so what at the user account settings which might affect Julia starting correctly. I’ve deleted all .bashrc, .profile, … still it is not starting in the original account.


#7

Where did you install the .app? Can you also try

<Juliaappdir>/Contents/Resources/script

#8

App was installed from .dmg and it goes to /Contents/MacOS
However, remarkably Julia is now starting - both 0.5 and 0.6. The reason is unclear. I had made all sorts of adjustments moving all Library/Preferences, running Disk Utility First Aid, deleting .bash_profile, .profile files but none of that worked. Only two things may have worked is cleaning up my Desktop (I deleted a few files) or plugging in and running my TimeMachine backup. So fixed but not solved. Thanks for the help.


#9

Puzzling. If you ever figure it out, let us know so we can try to fix the issue.