Nightly channel in Juliaup

Just a quick announcement: Juliaup now has support for a nightly channel. You typically get a prerelease build from the Julia master branch every day in that channel.

While the implementation for this channel is quite different from other channels, from a user point of view it works like any other channel. You add it with

juliaup add nightly

You run the nightly build with

julia +nightly

and you get new builds via

juliaup update

Enjoy and report any errors or problems here!

45 Likes

This is huge!!! For a lot of users (like myself) it means we can finally install nightly easily, and so we’re gonna start using it where we didn’t before

11 Likes

Just a quick note - you need to update to the latest version of juliaup (1.14.5)

The upgrade procedure is not all that obvious - I had to remove the existing juliaup then re-run the installation script.

juliaup self update was not working for you? I just tried and it upgraded to 1.14.5 in less than a second!

3 Likes

That wasn’t working for me yesterday on Windows but just ran it and worked perfectly.

2 Likes

Hmm, it’s not working for me on Windows. It just hangs after printing “An update is available.”

Duuh… The syntax for ‘juliaup self update’ only appears if you know to ask for 'juliaup self --help"

2 Likes

I found it in the general help:

The Julia Version Manager

Usage: juliaup <COMMAND>

Commands:
  default      Set the default Julia version
  add          Add a specific Julia version or channel to your system. Access via `julia +{channel}` e.g. `julia +1.6`
  link         Link an existing Julia binary to a custom channel name
  list         List all available channels
  override     Manage directory overrides
  update       Update all or a specific channel to the latest Julia version
  remove       Remove a Julia version from your system
  status       Show all installed Julia versions
  gc           Garbage collect uninstalled Julia versions
  config       Juliaup configuration
  self         Manage this juliaup installation
  completions  Generate tab-completion scripts for your shell
  help         Print this message or the help of the given subcommand(s)

(Third from the end). Then just typing juliaup self will show the self help. But yeah maybe one line about that in the general help would be nice.

The general philosophy for Juliaup is that it auto-updates. juliaup self update really is just for the impatient :wink:

There are various delays in place from the moment I publish a release: a) the auto-update feature on Linux/Mac only checks once a day for a new version (unless you configured something else), and b) for the Windows version there is quite a significant delay in the Windows Store publishing process (somewhere form a few hours to day[s]).

I think the lesson here is that I’ll wait posting an announcement until the Windows Store publishing process has finished, at that point the build should be available to everyone.

There should be a little dialog window somewhere on your screen at that point asking you whether you want to update. Are you running things from a Windows Terminal or something else?

2 Likes

Ah, I’m on Windows Terminal but my monitor is a secondary while my primary one is turned off. And I didn’t see anything in the task bar or the task-switch interface. I saw it after turning my other monitor on.

1 Like

Yeah, I wish that window would just appear center over the terminal, but haven’t been able to figure that one out…

2 Likes

Just saying, juliaup self update seems to work fine but on my two Arch (Endeavouros) systems, yay -Ss juliaup (check for updates) still tells me there’s a new version and that I have a slightly older one installed: aur/juliaup 1.14.5-2 (+7 0.62) (Installed: 1.14.5-1). Trying to update (reinstall) via yay -Syu juliaup fails to compile. This is not a complaint or anything I want someone to fix! I’m just reporting what I see. My Arch Linux is bang up-to-date. Can send error log if you are interested.

@togo59 maybe comment on AUR (en) - juliaup (or it might be the issue noted there already)

1 Like

jill has always provided this, so switching to juliaup surprised me when I found that this was missing

Same issue here. Haven’t had the time to investigate, just holding off on the update until someone else figures it out :stuck_out_tongue:

I had an identical issue of juliaup not updating. The only solution I had was a fresh reinstall. This was fairly easy for me (I had a lot of stuff in manifest/project toml) but I could see the difficulty for others.

If this is also easy for you, this might be fine.

I think the best advice here is to just install Juliaup via the shell script, rather than the AUR package manager, that should always give you the latest version of it.