Messed up environment UUID?

I’ve got some weird behavior with an environment: I renamed a file in the environment’s src and subsequently every time I tried to add or dev any other package with the project activated, I got an error:

ERROR: expected the file `src/oldname.jl` to exist for package `myenvt` at .../myenvt `

It’s completely bizarre to me that should get an error like that about a renamed file when trying to add a package dependency, especially since the text oldname appears nowhere in the project. Even more mystifying to me, deleting the UUID from myenvt's Project.toml fixed the problem.

What’s going in here. And how do I get a UUID back (if I need to)?

That sounds like a Revise message; I’d restart your Julia session. (In general you can’t change package versions after loading a package into your Julia session; Revise attempts to allow you to do that but sometimes it is unable and a restart is still needed).

The whole project is resolved together so the fact that you tried to add some other packages doesn’t really matter.

It probably exists in the manifest file.

1 Like

I am quite sure it is a Pkg error message.

1 Like

Oh, thanks for the correction then!

It’s Pkg, and it happens in a fresh session.