Makie package

question
package

#1

I have a problem with Makie package. On testing(Pkg.test(“Makie”)) it passed 81 of 100 tests. For example from these tests it didn’t passed test “heatmap Interpolation” where is the problem with vbox and hbox function which works in different package(“Interact.jl” which passed all the tests and just works) and “Mouse Picking” which have problem with on function(which also work in Interact package). I suspect the namespace conflict, but i’m not sure of that. Could you help me with this problem, if it’s more complicated, I can send some error comunicates from jupyter notebook.


#2

Ok, now I know new things. Some functions just have been depreciated or moved to other packages like linspace -> range or eye(x,x)->Matrix(I,x,x) and some of tests updates can’t keep up with these changes. If it goes about my topic problem, I still didn’t find the solution. I think it would be good to signalize these changes(actualizations and deprecations) in one topic, because these changes are too fast,


#3

Use version 0.7 if you’re upgrading packages to 1.0.

Makie is already 1.0 compatible, but it looks like the documentation build is broken so the stuff that appears online is out of date: https://github.com/JuliaPlots/Makie.jl/issues/148


#4

I’m not really sure what you’re doing, since on master no tests should pass (haven’t updated the reference images yet) on tagged version you shouldn’t run into the “on” function. Finally, I’m not sure where you’re getting the deprecated examples from, because I actually did just update the documentation a few days ago, so there shouldn’t be any place in either source or documentation with deprecated examples anymore…
Maybe everything just works fine, and the reference image tests just fail in 20% of the cases, because the installed fonts on your system are different - that’s a sort of known issue that I’ll fix soon!


#5

I can confirm what @sdanisch said, I just tested Makie 0.9.0 on my Mac and it worked. One “big data” test was dropped before running, otherwise all tests passed. I’m using Julia 1.0.0.


#6

I’m not sure if it will helps, but here are some screenshots will light up the problem.


#7


#8

failed_tests_2


#9


#10

and one of first screnshots:


#11

And also one example “Mouse Picking”(should work, but it don’t).example_(Mouse%20Picking)


#12

the tests look about right!
For the mouse picking example, you might need to say:

using Observables, Makie
...

#13

It still doesn’t work.
With adding this:


#14

Ah yeah, so you’re on the tagged version and trying the examples from the documentation :wink:
Sorry, in the rush to pack up a release, this got out of sync…
But master should be relatively stable:

]add Makie#master AbstractPlotting#master

#15

While ]add Makie it appears:


, so it seems I have to install again glfw, because I did it before, because I wrote
sudo apt-get install ffmpeg cmake xorg-dev in Linux Terminal.


#16

] up


Interact vs Makie
#17

It update GLFW and allow to install Makie from ]add Makie, but it still hadn’t change anything about the problem. Now I’m going sleep, but tomorrow I will continue to find an answer to this.


#18

Ok, I checked these tutorials and from example: quiver or contour examples works, but in test summary it shows that these examples not working(which isn’t true), but still it not working with examples with on(), hbox and vbox methods. In error it shows that is problem with AbstractPlotting, but I did almost everything with it and with Observables too. I have Julia version 1.0.2.