Makie marker as image

Hello :slight_smile:
I got an error, which wasn’t there at the previous versions of Makie.jl.
When I plot a scatter with marker set to an image as follow:

# I load the following Pkg:
using Makie
using CairoMakie
import GLMakie
# Then I create the main figure and an axis
fig = Figure(resolution = (700, 700))
ax1 =  Makie.Axis(fig)

# I have an image of a car named "marker_car" which was loaded from a png file
# and I pass this image as a marker
scatter!(ax1, car_pos, marker = marker_car, markersize= car_size)

Then I get the following error:

Error showing value of type Figure:
ERROR: MethodError: no method matching to_spritemarker(::RGBA{N0f8})
Closest candidates are:
  to_spritemarker(::Makie.FastPixel) at C:\Users\miki\.julia\packages\Makie\c5WJV\src\conversions.jl:1166
  to_spritemarker(::Circle{T} where T) at C:\Users\miki\.julia\packages\Makie\c5WJV\src\conversions.jl:1167
  to_spritemarker(::Type{var"#s298"} where var"#s298"<:(Circle{T} where T)) at C:\Users\miki\.julia\packages\Makie\c5WJV\src\conversions.jl:1168

What gone wrong?
thanks in a head


Since this is only getting a single color - Are you really passing an image?

hi, this is the type of the marker_car:

julia> typeof(marker_car)

so its a Matrix of RGBA which is the correct type for an image.

hello again
I think the issue is solved, I updated my opengl drivers for my windows and reinstall the Makie Pkg and now the errors are gone, I’m not sure what fixed it but now all is OK.
thank you all