[Makie.jl] All the symbols shown as boxes

Yesterday, Makie started showing boxes instead of all symbols in my plots. I tried everything that I could think of and don’t know what else to try to fix it. Can you point me in a direction?

  • I tried downgrading Makie but that does not fix it.
  • It is only a problem for WGLMakie and GLMakie, but mesa did not update from when it worked.
  • It did look like a font problem but when I try to specify any font, the plotting function throws an error:
julia> s = scatter(rand(Point2, 100), marker = :diamond, font = joinpath("/usr/share/fonts/TTF/", "Iosevka Thin Nerd Font Complete Mono.ttf"))
Error showing value of type Makie.FigureAxisPlot:
ERROR: MethodError: no method matching gl_convert(::FreeTypeAbstraction.FTFont)
Closest candidates are:
  gl_convert(::Quaternion) at ~/.julia/packages/GLMakie/TfSB1/src/GLVisualize/visualize/particles.jl:30
  gl_convert(::Function, ::Any) at ~/.julia/packages/GLMakie/TfSB1/src/GLAbstraction/GLUniforms.jl:264
  gl_convert(::T) where T<:GeometryBasics.Mesh at ~/.julia/packages/GLMakie/TfSB1/src/GLAbstraction/GLUniforms.jl:194

Seems related to this issue I opened a few days ago.

By any chance, are you using an unofficial build of Julia? In my case, I found out the issue was “fixed” by switching from a custom-compiled Julia (nothing fancy, I was using the default build parameters) to the official binaries. Not sure why though.

1 Like

This looks like it is exactly the same issue. I will try to compile julia from source and then try if it is fixed. Thanks!

It looks like it is possible that the issue is with the julia build because it was updated just about the time when this issue first occurred for me.

1 Like

I installed the beta3 binaries from the julia website and it works. Thank you!