load not defined

I’m new to Julia.

I’m trying to read image, here is my package status:

julia> Pkg.status()
    Status `C:\Users\ayakov\.julia\environments\v1.1\Project.toml`
  [c52e3926] Atom v0.8.2
  [34da2185] Compat v2.1.0
  [31c24e10] Distributions v0.17.0
  [89b67f3b] ExcelFiles v0.9.1
  [5789e2e9] FileIO v1.0.5
  [6218d12a] ImageMagick v0.7.1
  [86fae568] ImageView v0.8.2
  [916415d5] Images v0.17.3
  [e5e0dc1b] Juno v0.7.0
  [91a5bcdd] Plots v0.23.2
  [5e47fb64] TestImages v0.4.1
  [9a3f8284] Random

but when i’m running simple code like this:

using TestImages,Images
img = testimage("mandrill")

or :

 using Images
img = load("download.jpg")

I’m always getting:

LoadError: UndefVarError: load not defined

any ideas?

You need the FileIO package, I believe

] add FileIO
> using FileIO

That should work.

1 Like

I tried that also.
gave me the same error

1 Like

mmm, very weird, i literally copy-paste your code and it works. what julia version are you using?, are you doing this from a file or from the command line (REPL) ?

The newest one, I am using Juno and I try both PERL and script.

Can you please paste the entire code you ran and the complete error message?


I had same error.You have to use the package ImageIO in addition to FileIO

I alsor ran into this issue recently, and I fixed it by installing ImageMagick.