Convert not defined

Loading an Image worked fine for months and now suddenly I can’t make it work anymore (since my computer crashed, idk if this is in any way connected).

julia> Pkg.status()
    Status `C:\Users\immanueldiener\.julia\environments\v1.3\Project.toml`
  [c52e3926] Atom v0.12.9
  [fbb218c0] BSON v0.2.6
  [336ed68f] CSV v0.5.26
  [3895d2a7] CUDAapi v3.1.0
  [c5f51814] CUDAdrv v6.0.0
  [be33ccc6] CUDAnative v2.10.2
  [3a865a2d] CuArrays v1.7.3
  [a93c6f00] DataFrames v0.20.2
  [5721bf48] DataVoyager v1.0.0
  [5789e2e9] FileIO v1.2.4
  [587475ba] Flux v0.10.3
  [4d00f742] GeometryTypes v0.8.2
  [6a3955dd] ImageFiltering v0.6.11
  [82e4d734] ImageIO v0.1.1
  [6218d12a] ImageMagick v1.1.3
  [86fae568] ImageView v0.10.8
  [916415d5] Images v0.22.0
  [c8e1da08] IterTools v1.3.0
  [e5e0dc1b] Juno v0.8.1
  [7269a6da] MeshIO v0.4.0
  [e6723b4c] Meshing v0.5.3
  [91a5bcdd] Plots v0.29.7
  [438e738f] PyCall v1.91.4
  [ce6b1742] RDatasets v0.6.6
  [3646fa90] ScikitLearn v0.5.1
  [2913bbd2] StatsBase v0.32.2
  [b2279eaa] SurfaceGeometry v0.1.0 [`C:\Users\immanueldiener\.julia\dev\SurfaceGeometry`]
  [0ae4a718] VegaDatasets v2.0.0
  [8ba89e20] Distributed

Whenever i try this:

using Images
img = Images.load("path")

I get this error:

UndefVarError: convert not defined

I am trying to load .tif images, which worked fine in the past as I said. But even if I try to load any other format, such as .PNG, it doesn’t work.

I can still use the

convert()

function as usual.

What comes after this? The part you have excluded from the stacktrace is probably pointing to the source of the problem.

1 Like

This follows:

in top-level scope at test.jl:2
in load at FileIO\Glbhe\src\loadsave.jl:118
in #load#13 at FileIO\Glbhe\src\loadsave.jl:118 
in load at FileIO\Glbhe\src\loadsave.jl:169 
in #load#27 at FileIO\Glbhe\src\loadsave.jl:189
in handle_exceptions at FileIO\Glbhe\src\error_handling.jl:77
in handle_error at FileIO\Glbhe\src\error_handling.jl:82

There was an update to ImageMagick_jll that ended up exporting convert. Imagemagick.jl has recently fixed this: https://github.com/JuliaIO/ImageMagick.jl/commit/c347fb978f2f1353b170c90f70e9eeb11850c597

An update has been submitted, try updating ImageMagick or using ]add ImageMagick#master

The update did it, thank you!