HELP! Can not install packages... Git can not clone https://github.com/JuliaRegistries/General.git

Hello,

I have a manjaro installed pc. I installed julia through manjaro package management system (pacman). The installed julia version is 1.3.1. I tried to install several packages from RELP but I receive following error

julia> 
(v1.3) pkg> add DataFrames
   Cloning default registries into `~/.julia`
   Cloning registry from "https://github.com/JuliaRegistries/General.git"
ERROR: failed to clone from https://github.com/JuliaRegistries/General.git, error: GitError(Code:ERROR, Class:Invalid, invalid version 0 on git_proxy_options) 

However I can manually clone via

git clone https://github.com/JuliaRegistries/General.git 

Git is working as expected. I am behind a firewall but the pc can access internet without proxy settingsā€¦
Any help much appreciated.

You are hitting this issue:

The current solutions are to either downgrade your libgit2, or to download the registry manually to ~/.julia/registries/General

2 Likes

Yes, thank you for pointing out. I am using manjaro which is rolling release based on arch so I can not or could not downgrade the libgit2 to 0.22 which seems quite old.

I have circumvent the problem, by manually pulling JuliaRegistries under ~/.julia/registries directory. After that packages can be installed but updating still fails. I tried to manually update all repo via git pull but after that some of builds got brokenā€¦So as long as the whole repository is update via Pkg.update command, everthing seems working fine. I am waiting release of 1.4 which supposed to solve this problem.