Juno refuses to calculate anything (REPL ok)


#1

This have happened the last few days, I have tried restarting Juno without any change.

After starting Atom I click enter in the REPL to start Julia and get this printed:

Press Enter to start Julia.
               _
   _       _ _(_)_     |  A fresh approach to technical computing
  (_)     | (_) (_)    |  Documentation: https://docs.julialang.org
   _ _   _| |_  __ _   |  Type "?help" for help.
  | | | | | | |/ _` |  |
  | | |_| | | | (_| |  |  Version 0.6.2 (2017-12-13 18:08 UTC)
 _/ |\__'_|_|_|\__'_|  |  Official http://julialang.org/ release
|__/                   |  x86_64-pc-linux-gnu

ERROR: Invalid history file (/home/Torkel.Loman/.julia_history) format:
If you have a history file left over from an older version of Julia,
try renaming or deleting it.
Invalid character: '1' at line 1
Stacktrace:
 [1] hist_from_file(::Base.REPL.REPLHistoryProvider, ::IOStream, ::String) at ./REPL.jl:352
 [2] #setup_interface#23(::Bool, ::Array{Dict{Any,Any},1}, ::Function, ::Base.REPL.LineEditREPL) at ./REPL.jl:771
 [3] run_frontend(::Base.REPL.LineEditREPL, ::Base.REPL.REPLBackendRef) at ./REPL.jl:940
 [4] run_repl(::Base.REPL.LineEditREPL, ::Base.##510#511) at ./REPL.jl:180
 [5] _start() at ./client.jl:413

In addition this red error message appears in the upper right corner of Juno

Julia Client – Internal Error

UndefRefError: access to undefined reference
changeREPLmodule(::String) at repl.jl:99
(::Atom.##139#140)(::Dict{String,Any}) at repl.jl:27
handlemsg(::String, ::Dict{String,Any}, ::Vararg{Dict{String,Any},N} where N) at comm.jl:163
(::Atom.##11#13)() at event.jl:73

I have seen these kind of errors before and haven’t really cared since everything worked fine. Now how ever, things are not working fine. I can use the REPL as normal. However, if I try to execute anything in the files above (like 1+1) using Shift+Enter the cogs appear to the right of the line, but stays there forever. Basically I can only use the REPL and the things I try to execute in the files do not work (this is not good).

Is this a know issue, might the error messages have anything to do with it?


#2

As the error message says, try renaming or deleting /home/Torkel.Loman/.julia_history. Also try Pkg.update()ing and updaing the Atom packages julia-client and ink. If that doesn’t work, can you provide the output of Pkg.status()?


#3

Thank you for the help! Deleting the history file did not fix the issue (but did remove those irritating error messages).

However, updating julia-client and ink did work, cheers.