JuliaUp fails to install: "Error: Failed to download from"

I got a new ubuntu 22.04 machine, and tried:

torkelloman@system76-pc:~$ curl -fsSL https://install.julialang.org | sh

I got an output

info: downloading installer
Welcome to Julia!

This will download and install the official Julia Language distribution
and its version manager Juliaup.

Juliaup will be installed into the Juliaup home directory, located at:


The julia, juliaup and other commands will be added to
Juliaup's bin directory, located at:


This path will then be added to your PATH environment variable by
modifying the profile files located at:


Julia will look for a new version of Juliaup itself every 1440 minutes when you start julia.

You can uninstall at any time with juliaup self uninstall and these
changes will be reverted.

✔ Do you want to install with these default configuration choices? · Proceed with installation

Now installing Juliaup
Error: Failed to download from url `https://julialang-s3.julialang.org/juliaup/bin/juliaup-1.8.12-x86_64-unknown-linux-musl.tar.gz`.

Caused by:
    0: https://julialang-s3.julialang.org/juliaup/bin/juliaup-1.8.12-x86_64-unknown-linux-musl.tar.gz: Connection Failed: Connect error: Network unreachable (os error 101)
    1: Network unreachable (os error 101)

I can then confirm that JuliaUp didn’t isntall:

torkelloman@system76-pc:~$ juliaup list
juliaup: command not found

However, I am able to simply enter “https://julialang-s3.julialang.org/juliaup/bin/juliaup-1.8.12-x86_64-unknown-linux-musl.tar.gz” in my browser and a file downloads normally. I have a internet connection that seems fine and stable.

While I vaguely understand what went wrong, I don’t really know how to proceed from here, and I haven’t found any mention of the error.

Perhaps you need to open a new shell so that the changes in .bashrc and .profile can take effect.

echo $PATH


env | grep PATH

would tell you if /home/torkelloman/.juliaup/bin is already part of PATH environment variable in your current shell.

Well sorry, I missed the error message in your post. So my response is probably not helpful for you.

Why should you be able to download the URL but curl is not? what is the vague understanding you are hiding :wink: from us?

1 Like

Ok, seems restarting the machine solved this, should have tried that first before panicking :sweat_smile: