JuliaBox: unable to connect to Julia

juliabox

#1

Hi,
I’m trying to use JuliaBox, and I’m getting this error:

A connection to the notebook server could not be established. The notebook will continue trying to reconnect, but until it does, you will NOT be able to run code. Check your network connection or notebook server configuration.

Please do let me know if I’m missing something.

Thanks.


#2

Maybe a temporary network or server problem? juliabox.com works for me right now.


#3

Hey Steven,

It still says unable to connect to a kernel. I’ve tried all the choices of kernels (Julia 0.3 to 0.6 )- and yet it says Connection failed.


#4

Under “settings” there is a “network connectivity test” that may provide further information. BTW, I get the same error when I’m behind a firewall.

– mb


#5

The network connectivity test says:

Testing secure websocket (port 443) connectivity…

connecting...

connected...

sent message...

received response. test successful

disconnected.

All tests passed.

I’ve disabled the Windows firewall, but no luck either.


#6

You might want to try a different browser and/or network provider. If it still doesn’t work, you can always simply download Julia and run examples from notebooks right in the REPL.


#7

Are you trying to use the Edge browser? I don’t think JuliaBox works correctly in Edge right now. That should ideally be reported and fixed if possible.


#8

I’m using Firefox and Chrome - both have the same error.
Maybe its an antivirus thing - not sure.
Yeah, I already have Julia installed, just wanted to use this to show JuliaBox in a classroom setting.
I’ll show them the downloaded version I guess.

Thanks anyway!


#9

@creative.user.name This is an old post, but I have the same issue. Checking in to see whether you ended up finding a solution to this…

Thanks,
J.L


#10

No, I couldn’t find a solution. I used the local version of Julia.


#11

Are you using any kind of adblockers? If so, please relax your settings and/or turn off filtering for juliabox.com.


#12

When I get this error I simply start another julia box without closing the old ones.
It works and I can save my works etc…
Give that a try maybe it works.


#13

Hi, I have the same problem. I got a message
"A connection to the notebook server could not be established. The notebook will continue trying to reconnect. Check your network connection or notebook server configuration"

I used window 10 64 bit, Chrome, also I have bitdefender antivirus.

Any solutions or suggestions?


#14

It’s probably Bitdefender’s fault. I had the same problem (a few months back), replaced Bitdefender with something else - and JuliaBox started to work. Alternatively, you could try to tweak the firewall settings. (No, I don’t know how.)

/Paul S