JuliaAstro travis ci migration

Hi all

I have received an email from travis ci saying that we need to migrate our projects from Travis-ci.org to Travis-ci.com.

But it does not seem like I can migrate my project JuliaAstro/CALCEPH.jl
Probably I don’t have enough authorizations for the JuliaAstro organization.

Is someone taking care of moving all JuliaAstro projects?

Thank you

Isn’t travis-ci.com already enabled on all repositories of the organisation?

I got that email and checked my own CI, which was already on travis.com. I don’t think I did anything special to use that instead of travis.org when I started using Travis in the first place. It just happened.

I was happy to see that I don’t have to do anything about this while I try to figure out github actions.

See https://travis-ci.com/github/JuliaAstro

Only a few repos were built with last build 21 days ago

Whereas https://travis-ci.org/github/JuliaAstro
more repos builds and last build 6 days ago

so it does not look like all of JuliaAstro has migrated.

When I tried to follow the migration procedure, it only proposed to me migration of repos under my user name, not repos under JuliaAstro such as CALCEPH.jl

And so? That shows that .com is available for repositories under the organisation

What’s the migration procedure? Travis usually requires very little rights (just write access to the repo), I’m surprised you have any problem

Basically visiting:

but it does not allow me to select repositories in JuliaAstro only under my username.

Also if I go to:

it says I have insufficient permissions to access settings for my package CALCEPH.jl

Can you try again now?

Thank you @giordano . I can now access CALCEPH.jl settings in https://travis-ci.org/organizations/JuliaAstro/repositories

However there is no migration option in settings. In the migrate tool, https://travis-ci.com/account/migrate
I still do not see JuliaAstro/CALCEPH.jl in the list of repos I can migrate. Since I can only migrate repos under my user name, I guess CALCEPH.jl must be migrated by a JuliaAstro owner.

Can you go to https://travis-ci.com/organizations/JuliaAstro/migrate and select CALCEPH.jl? I’m trying to understand how this tool works

Thank you again @giordano . This worked: CALCEPH was the only package I was allowed to select. Migration is in progress. Let’s see if it completes.