Julia 0.5 can't load basic modules


#1

Hi, I’ve upgraded to Julia-0.5, but having some trouble with very basic setup.

In short, I can’t get any modules to load, even after verifying LOAD_PATH includes the directory where the modules are stored.

Using Win7 x64.

Starting with Pkg.add("Atom"), it fails with building HttpParser because it can’t find BinDeps.

Turns out Pkg.add(...) puts packages in c:\users\me\.julia\v0.5, but LOAD_PATH is by default set to a couple places in AppData\Local\..., so in fact none of the modules that are installed are useable.

So I add the module path to LOAD_PATH by saying push!(LOAD_PATH, Pkg.dir()), but no luck. I also tried changing the capitalization of the path, but I don’t think this matters. Not sure why I need to do this out of the box. I didn’t see any “julia” in the Windows registry which might impact an install after a previous 0.4.5 install.

Here is now my LOAD_PATH, and confirmation that BinDeps is installed, as far as Pkg is concerned.

julia> LOAD_PATH
2-element Array{String,1}:
 "C:\\Users\\me\\AppData\\Local\\Julia-0.5.0\\local\\share\\julia\\site\\v0.5"
 "C:\\Users\\me\\AppData\\Local\\Julia-0.5.0\\share\\julia\\site\\v0.5"

julia> push!(LOAD_PATH, Pkg.dir())
3-element Array{String,1}:
 "C:\\Users\\me\\AppData\\Local\\Julia-0.5.0\\local\\share\\julia\\site\\v0.5"
 "C:\\Users\\me\\AppData\\Local\\Julia-0.5.0\\share\\julia\\site\\v0.5"
 "c:\\users\\me\\.julia\\v0.5"

julia> using BinDeps
ERROR: ArgumentError: Module BinDeps not found in current path.
Run `Pkg.add("BinDeps")` to install the BinDeps package.
 in require(::Symbol) at .\loading.jl:365

julia> Pkg.installed("BinDeps")
v"0.4.5"

From the cmd shell, I confirm that BinDeps is in the location shown above:

C:\users\me\.julia\v0.5>dir
 Volume in drive C is Windows7_OS
 Volume Serial Number is A486-AC98

 Directory of C:\users\me\.julia\v0.5

01/06/2017  08:56 AM    <DIR>          .
01/06/2017  08:56 AM    <DIR>          ..
01/06/2017  08:56 AM    <DIR>          .cache
01/06/2017  08:56 AM    <DIR>          AbstractTrees
01/06/2017  08:56 AM    <DIR>          ArgParse
01/06/2017  08:56 AM    <DIR>          ASTInterpreter
01/06/2017  08:56 AM    <DIR>          Atom
01/06/2017  08:56 AM    <DIR>          BinDeps
<more>

Any idea how to get this working?

Thanks


#2

I’ve found the answer here:

I too had all lowercase in my HOME environment variable. Changing c:\users\... to C:\Users\... fixed it.
Took me a day and a half, three reinstalls, and 4 forum posts to figure this out! :slight_smile: