Issues with JuMPeR

package

#1

Hi I have a legacy code in JuMPeR which I’m trying to run with the latest version of JuMP and Julia.
The command setDefaultOracle is not recognized, and I can not find what it was changed to.
Does anybody know what it was changed to? did GeneralGraphOracle change as well?

I also tried to run Pkg.test(“JuMPeR”) and got:
ERROR: LoadError: Some tests did not pass: 1628 passed, 309 failed, 74 errored.
I can send the full report if anyone is maintaining the package


#2

According to its REQUIRE file, JuMPeR is compatible with JuMP 0.14 and no later, while the latest version of JuMP is 0.16. So I wouldn’t expect to run JuMPeR with the latest version of JuMP unless you’re willing to or can find someone willing to update it.


#3

Looking at the commit history, @yeesian has recently made updates to JuMPeR, he may provide more information.


#4

In general, you can use the search bar in github to search for the method/function that you’re trying to call to see when it has changed.

I have not tried it myself, but it seems you might just need to call setDefaultOracle! instead of setDefaultOracle.


#5

JuMP actally reverted to the 0.14 version but it still did not work


#6

Thanks for the tip
I actually tried running the command
setDefaultOracle!(rm, JuMPeR.GeneralGraphOracle())
and got the error:
ERROR: LoadError: UndefVarError: setDefaultOracle! not defined