Issue with a GtkReactive example

question

#1

Can you please try this drawing example from GtkReactive:

include(joinpath(Pkg.dir("GtkReactive"), "examples/drawing.jl"))

It runs without any errors/warnings but for some reason it does not draw anything (lines are supposed to show up on the canvas when you click and draw). I’m afraid it has something to do with the last problem we had with Cairo (see issues here and here), but I don’t know.


#2

What do you mean with

i see the same like above

ERROR: Cairo.CairoContext must implement reset_transform

#3

Ah, sorry, after pinning Cairo at 4.


#4

After

Pkg.pin(“Cairo”,v"0.4.0")

the example works - drawing in red, lines are recorded in blue.


#5

Waaaaat… wow. So no idea why it’s not working for me :astonished:


#6

It works!!!
No flipping idea what went wrong.


#7

just to mention this: getting a julia repository into a well defined state (incl. package versions AND precompiled .ij) is still an experimental feature and you even see well known developers recommending to start over with an empty .julia/v0.6. I set my hopes into Pkg3.


#8

I got a bit confused, I also get the same error as @lobingera:

ERROR: Cairo.CairoContext must implement reset_transform

I’ve seen the issues linked above and pinned to Cairo v0.4 and that fixed it, but shouldn’t GtkReactive add an upper bound on Cairo if it doesn’t support its latest release?


#9

Sounds good.


#10

Did this ever get solved? Or did it just randomly stop failing for you. I’ve had this problem for a very long time (exactly as first described above).

Just to clarify… I have Cairo pinned at v0.4. I have tried the example from the REPL and from Juno and even tried to run it by copy-pasting the code and running it that way. In all cases the window is created and no errors are generated whatsoever but drawing does not work. Since no errors are thrown I am not sure where to look.

Unless the problem has been clearly identified I think it might be good to revisit this issue. There may be others having problems who -like myself- never said anything.

I don’t know if this is important but I have had this problem on three computers and through several versions of julia.


#11

i’m working on a new release of Cairo inlc. this, but i have some github problems today, so i cannot test all - esp. recent 0.7