GitHub Actions: Cairo fails to build

Can’t figure out why. There appears to be issues compiling HarfBuzz_jll , Pango_jll , then eventually Cairo.

Here is a link to a sample run demonstrating this issue:
Try to better match what was done in Gtk/Cairo. · ma-laforge/InspectDR.jl@9e55b8a · GitHub


  • :white_check_mark: (passes) Julia 1.3 (ubuntu, windows, macos)
  • :white_check_mark: (passes) Julia 1/nightly (ubuntu)
  • :x: (fails) Julia 1/nightly (windows)
  • :x: (fails) Julia 1/nightly (macos)

I tried mirroring what I saw in the ci.yml files of Gtk.jl & Cairo.jl:

  • actions/cache@v1 → v2
  • julia-actions/julia-buildpkg@v1 → latest
  • julia-actions/julia-runtest@v1 → latest

But it didn’t appear to help.

Worked 2 months ago

Before Julia v1.6 was released. Actually, my last working CI run from 2 months ago seems to have just made a successful execution on a Julia v1.6.0 release.

Any idea what is causing this issue?

I think this problem is quite recent - Cairo artifacts issues · Issue #154 · JuliaGraphics/Luxor.jl · GitHub

Something amiss with the artifacts apparently.

Try again now


Everything works now. Thanks!