Is there an error with the Sundials package (part of DifferentialEquations package)?

Hello guys (this is my first topic)

I’m trying to download the DIfferentialEquations package in order to solve some ODEs. However, I have a real difficulty downloading the sundials package which is installed during add DifferentialEquations. Eveyrthing is added correctly except this specific package. Other installed packages such as Ipopt and JuMP are fully functional so this very specific error is odd to me.

I was wondering if there’s an error in the package or that I’m doing something wrong? I have tried different solutions on the net such as update and manually add sundials, but it simply does not work.

Here’s the error message (I was only allowed to embed one single media file)

1 Like

Rest of the error messages:

Are you using a 32-bit version of Julia? Is your Julia downloaded from Download Julia ?

No problem on Ubuntu 20.04:

ufechner@tuxedi:~/repos/sundials$ julia --project="."
   _       _ _(_)_     |  Documentation:
  (_)     | (_) (_)    |
   _ _   _| |_  __ _   |  Type "?" for help, "]?" for Pkg help.
  | | | | | | |/ _` |  |
  | | |_| | | | (_| |  |  Version 1.8.2 (2022-09-29)
 _/ |\__'_|_|_|\__'_|  |  Official release
|__/                   |

(sundials) pkg> add Sundials
    Updating registry at `~/.julia/registries/General.toml`
   Resolving package versions...
    Updating `~/repos/sundials/Project.toml`
  [c3572dad] + Sundials v4.10.1
    Updating `~/repos/sundials/Manifest.toml`
  [79e6a3ab] + Adapt v3.4.0
  [4fba245c] + ArrayInterface v6.0.23
  [30b0a656] + ArrayInterfaceCore v0.1.20
  [015c0d05] + ArrayInterfaceOffsetArrays v0.1.6
  [b0d46f97] + ArrayInterfaceStaticArrays v0.1.4
  [dd5226c6] + ArrayInterfaceStaticArraysCore v0.1.0
  [62783981] + BitTwiddlingConvenienceFunctions v0.1.4
  [fa961155] + CEnum v0.4.2
  [2a0fbf3d] + CPUSummary v0.1.27
  [49dc2e85] + Calculus v0.5.1
  [d360d2e6] + ChainRulesCore v1.15.6
  [9e997f8a] + ChangesOfVariables v0.1.4
  [fb6a15b2] + CloseOpenIntervals v0.1.10
  [38540f10] + CommonSolve v0.2.1
  [bbf7d656] + CommonSubexpressions v0.3.0
  [34da2185] + Compat v4.3.0
  [187b0558] + ConstructionBase v1.4.1
  [adafc99b] + CpuId v0.3.1
  [9a962f9c] + DataAPI v1.12.0
  [864edb3b] + DataStructures v0.18.13
  [e2d170a0] + DataValueInterfaces v1.0.0
  [b429d917] + DensityInterface v0.4.0
  [2b5f629d] + DiffEqBase v6.105.1
  [163ba53b] + DiffResults v1.1.0
  [b552c78f] + DiffRules v1.11.1
  [31c24e10] + Distributions v0.25.75
  [ffbed154] + DocStringExtensions v0.9.1
  [fa6b7ba4] + DualNumbers v0.6.8
  [7034ab61] + FastBroadcast v0.2.1
  [1a297f60] + FillArrays v0.13.4
  [6a86dc24] + FiniteDiff v2.15.0
  [f6369f11] + ForwardDiff v0.10.32
  [069b7b12] + FunctionWrappers v1.1.3
  [77dc65aa] + FunctionWrappersWrappers v0.1.1
  [46192b85] + GPUArraysCore v0.1.2
  [3e5b6fbb] + HostCPUFeatures v0.1.8
  [34004b35] + HypergeometricFunctions v0.3.11
  [615f187c] + IfElse v0.1.1
  [3587e190] + InverseFunctions v0.1.8
  [92d709cd] + IrrationalConstants v0.1.1
  [42fd0dbc] + IterativeSolvers v0.9.2
  [82899510] + IteratorInterfaceExtensions v1.0.0
  [692b3bcd] + JLLWrappers v1.4.1
  [10f19ff3] + LayoutPointers v0.1.10
  [2ab3a3ac] + LogExpFunctions v0.3.18
  [bdcacae8] + LoopVectorization v0.12.132
  [1914dd2f] + MacroTools v0.5.10
  [d125e4d3] + ManualMemory v0.1.8
  [e1d29d7a] + Missings v1.0.2
  [46d2c3a1] + MuladdMacro v0.2.2
  [77ba4419] + NaNMath v1.0.1
  [8913a72c] + NonlinearSolve v0.3.22
  [6fe1bfb0] + OffsetArrays v1.12.7
  [bac558e1] + OrderedCollections v1.4.1
  [90014a1f] + PDMats v0.11.16
  [d96e819e] + Parameters v0.12.3
  [f517fe37] + Polyester v0.6.15
  [1d0040c9] + PolyesterWeave v0.1.10
  [21216c6a] + Preferences v1.3.0
  [1fd47b50] + QuadGK v2.5.0
  [3cdcf5f2] + RecipesBase v1.3.0
  [731186ca] + RecursiveArrayTools v2.32.0
  [f2c3362d] + RecursiveFactorization v0.2.12
  [189a3867] + Reexport v1.2.2
  [ae029012] + Requires v1.3.0
  [79098fc4] + Rmath v0.7.0
  [3cdde19b] + SIMDDualNumbers v0.1.1
  [94e857df] + SIMDTypes v0.1.0
  [476501e8] + SLEEFPirates v0.6.36
  [0bca4576] + SciMLBase v1.59.4
  [efcf1570] + Setfield v1.1.1
  [66db9d55] + SnoopPrecompile v1.0.1
  [a2af1166] + SortingAlgorithms v1.0.1
  [276daf66] + SpecialFunctions v2.1.7
  [aedffcd0] + Static v0.7.7
  [90137ffa] + StaticArrays v1.5.9
  [1e83bf80] + StaticArraysCore v1.4.0
  [82ae8749] + StatsAPI v1.5.0
  [2913bbd2] + StatsBase v0.33.21
  [4c63d2b9] + StatsFuns v1.0.1
  [7792a7ef] + StrideArraysCore v0.3.15
  [c3572dad] + Sundials v4.10.1
  [3783bdb8] + TableTraits v1.0.1
  [bd369af6] + Tables v1.9.0
  [8290d209] + ThreadingUtilities v0.5.0
  [d5829a12] + TriangularSolve v0.1.14
  [410a4b4d] + Tricks v0.1.6
  [3a884ed6] + UnPack v1.0.2
  [3d5dd08c] + VectorizationBase v0.21.51
  [700de1a5] + ZygoteRules v0.2.2
  [efe28fd5] + OpenSpecFun_jll v0.5.5+0
  [f50d1b31] + Rmath_jll v0.3.0+0
  [fb77eaff] + Sundials_jll v5.2.1+0
  [0dad84c5] + ArgTools v1.1.1
  [56f22d72] + Artifacts
  [2a0f44e3] + Base64
  [ade2ca70] + Dates
  [8ba89e20] + Distributed
  [f43a241f] + Downloads v1.6.0
  [7b1f6079] + FileWatching
  [9fa8497b] + Future
  [b77e0a4c] + InteractiveUtils
  [b27032c2] + LibCURL v0.6.3
  [76f85450] + LibGit2
  [8f399da3] + Libdl
  [37e2e46d] + LinearAlgebra
  [56ddb016] + Logging
  [d6f4376e] + Markdown
  [ca575930] + NetworkOptions v1.2.0
  [44cfe95a] + Pkg v1.8.0
  [de0858da] + Printf
  [3fa0cd96] + REPL
  [9a3f8284] + Random
  [ea8e919c] + SHA v0.7.0
  [9e88b42a] + Serialization
  [6462fe0b] + Sockets
  [2f01184e] + SparseArrays
  [10745b16] + Statistics
  [4607b0f0] + SuiteSparse
  [fa267f1f] + TOML v1.0.0
  [a4e569a6] + Tar v1.10.1
  [8dfed614] + Test
  [cf7118a7] + UUIDs
  [4ec0a83e] + Unicode
  [e66e0078] + CompilerSupportLibraries_jll v0.5.2+0
  [deac9b47] + LibCURL_jll v7.84.0+0
  [29816b5a] + LibSSH2_jll v1.10.2+0
  [c8ffd9c3] + MbedTLS_jll v2.28.0+0
  [14a3606d] + MozillaCACerts_jll v2022.2.1
  [4536629a] + OpenBLAS_jll v0.3.20+0
  [05823500] + OpenLibm_jll v0.8.1+0
  [bea87d4a] + SuiteSparse_jll v5.10.1+0
  [83775a58] + Zlib_jll v1.2.12+3
  [8e850b90] + libblastrampoline_jll v5.1.1+0
  [8e850ede] + nghttp2_jll v1.48.0+0
  [3f19e933] + p7zip_jll v17.4.0+0

(sundials) pkg> st
Status `~/repos/sundials/Project.toml`
  [c3572dad] Sundials v4.10.1

julia> using Sundials


Did you try in an empty project?

I don’t think it’s empty project or anything. It’s saying a Int64 ended up where an Int32 is, and that Int32 may just be an Int, so it could be a 32-bit OS thing. So sharing versioninfo() and such would be really helpful because it’s something about a non-standard installation or non-standard OS.

Thanks for the suggestions guys. I will check them out when I have access to my computer again tomorrow. I tried to download sundials on my friends laptop and there were no problems. So it appears that it’s only an user error related to my laptop

Here’s the version info:

And yes I downloaded Julia from the official website and it was automatically placed in:
C:\Users\erlin\AppData\Local\Programs\Julia-1.8.2\bin. If I recall correctly I used the 32bit installer.

Is there a reason why you are using the 32 bit version of Julia? The support is not as good as for the 64 bit version:

Tier 2: Julia is guaranteed to build from source using 
the default build options, but may or may not pass all tests. 
Official binaries are available on a case-by-case basis. 

Perhaps it is this bug: Segmentation fault in tests on 32-bit architectures (i686 and arm) · Issue #223 · SciML/Sundials.jl · GitHub ?

Good new guys it’s working now. I double checked my laptop specs and I should’ve installed the 64 bit julia from the beginning (The laptop was actually operating at 64 bit all along). When reinstalling differentialequations with 64 bit julia there were no problems anymore. I’m however unsure if this is an user error or bug that is worth raising an issue of?

Thanks alot! :slight_smile:

It is a bug I will look into, but being a 32-bit one makes it a much lower priority than most things on the list.