Installing Julia 0.4


#1

I need to debug some legacy Julia package developed for Julia 0.4. What is the best way to install Julia 0.4 on macOS 10.13 (High Sierra, the most recent macOS)? I tried several methods, but none of them worked.

  • I checked out the “release-0.4” branch of the JuliaLang/julia GitHub repository, but building it failed with an error. (This is the way I usually build versions > 0.4 successfully.)
  • I downloaded the v0.4.7 tarball from https://julialang.org/downloads/oldreleases.html/, but building it also failed with an error.
  • I downloaded the v0.4.7 disk image (dmg) from https://julialang.org/downloads/oldreleases.html/ and installed the app from it, but executing the app does not start REPL in Terminal.

I will appreciate any suggestions!


#2

Maybe go the other way around, install the latest stable Julia (v0.62) and try to bring that old code up to date?


#3

Posting the errors might help others to figure out how fix it.


#4

Any chance you can try this on an older OS? It is unlikely a software will work on an OS released 3 years after the software itself was released. I have the 0.4 binaries running on ElCapitan, and it works pretty well. An older linux would work as well.


#5

The Linux 0.4 binaries work fine in a Ubuntu 16.04 VM for example.


#6

Version 0.5 may also be worth a try (especially if you know that the code runs flawlessly under 0.4; that is not evident to me from your post though)


#7

Julia v0.4 works fine on my mac High Sierra (10.13.3). I’m running version v0.4.7

Julia Version 0.4.7
Commit ae26b25 (2016-09-18 16:17 UTC)

I still have the installation file (dmg) that seems different from the one you refer to:

MD5 (julia-0.4.7-osx10.7+.dmg) = 97386dd1cc38971173de7a533865de73

If you want I can upload it somewhere for you, just send me a private message.


#8

I recently built 0.4 on macOS 10.13.3. I started with julia-0.4.7-full.tar.gz. I compiled with:

make  OPENBLAS_TARGET_ARCH=NEHALEM

#9

Thanks, all! I used @jmkuhn’s method and was able to build v0.4.7 successfully.


#10

Sorry, I was building a wrong version. The problem persists. This is the error I got with @jmkuhn’s method:

~/packages/julia/julia-0.4.7/usr/lib/libprofile_rt.a
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   357  100   357    0     0   2313      0 --:--:-- --:--:-- --:--:--  2364
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
curl: (22) The requested URL returned error: 404 Not Found
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
curl: (22) The requested URL returned error: 404 Not Found
make[1]: *** [pcre2-10.20.tar.bz2] Error 22
make: *** [julia-deps] Error 2

#11

This means that curl (the download command-line tool) cannot access the url pointing, presumably, to pcre2-10.20.tar.bz2. Your internet connection works and no firewall is interfering?


#12

Considering the imminent release of 0.7 and its special nature as containing the last breaking language changes until 2.0, I feel compelled to suggest that you redirect whatever time and effort you would spend getting 0.4 to work into getting your code working on 0.6 or later.


#13

@yakir12, @ExpandingMan, that’s exactly what I am trying to do. I am trying to update someone else’s code written for v0.4. I want to update it for v0.6, my preferred version. For that, I am preparing the environment where the old code runs (= Julia v0.4), so that I can compare the results of the old code with the new updated code.


#14

@mauro3, my Internet connection works (as I am posting these messages now), but I’m not sure about firewall… Is there any way to reveal the URL it is trying to access?


#15

If you’re having trouble running v0.4 on your current OS, it might be easiest just to use a different OS. In particular, I know that the official Julia v0.4 binaries work just fine on Ubuntu 16.04. I would suggest using Ubuntu inside Docker on your mac as a way to get a nice, self-contained copy of v0.4 running.


#16

If you download:

https://github.com/JuliaLang/julia/releases/download/v0.4.7/julia-0.4.7-full.tar.gz

This already contains pcre2-10.20.tar.bz2 so you won’t need to download using curl during the build process


#17

@jmkuhn, thanks a lot! This time it worked flawlessly!!!