Importing packages takes very long inside jupyter notebook


Is there any particular resoan that importing packages in Jupyter notebook takes quite a long time. Every time it takes somewhere around 7 minutes while when not working with jupyter the import only takes a few second.


Do you observe this in “normal” Jupyter notebooks (with IJulia) or only in the VSCode extension notebooks?

Hi @nilshg Yes, only with extension. I’ve never tried Ijulia for this problem of mine because I need to rerun some cells and Ijulia sometimes returns some error of “multiple definition…”.

Are you sure you aren’t consufing IJulia with Pluto? The multiple definitions for... error is a Pluto thing, which I haven’t seen in IJulia notebooks.

Unless it’s actually the redefinition of a constant?

But that should be ERROR: invalid redefinition of constant rather than multiple definitions for

1 Like

@nilshg yes, you’re right I’ve mixed those. Sorry. I’m inside Jupyter notebook extension of Vscode IJulia and importing takes considerable amont of time comparing to plain vscode .jl files.

And what about regular IJulia notebooks in the Browser? I’m not sure about the status of notebook support in the VSCode extension, when I last tried it a year ago or so it was definitely still a bit rough around the edges, partly because the upstream functionality in VSCode was also still pretty new and under development.