(v1.0) pkg> add
Cloning git-repo
Updating git-repo
Resolving package versions…
Updating ~/.julia/environments/v1.0/Project.toml
[6218d12a] ↑ ImageMagick v0.7.1 ⇒ v0.7.1+ #master (
Updating ~/.julia/environments/v1.0/Manifest.toml
[6218d12a] ↑ ImageMagick v0.7.1 ⇒ v0.7.1+ #master (
Building ImageMagick → ~/.julia/packages/ImageMagick/at2AC/deps/build.log
┌ Error: Error building ImageMagick:
│ ┌ Warning: platform_key() is deprecated, use platform_key_abi() from now on
│ │ caller = ip:0x0
│ └ @ Core :-1
│ [ Info: Downloading to /home/users/xdlan/.julia/packages/ImageMagick/at2AC/deps/usr/downloads/Zlib.v1.2.11.x86_64-linux-gnu.tar.gz…
│ ERROR: LoadError: LoadError: Could not download to /home/users/xdlan/.julia/packages/ImageMagick/at2AC/deps/usr/downloads/Zlib.v1.2.11.x86_64-linux-gnu.tar.gz:
│ ErrorException("")
│ Stacktrace:
│ [1] error(::String) at ./error.jl:33
│ [2] macro expansion at ./logging.jl:313 [inlined]
│ [3] #download#89(::Bool, ::Function, ::String, ::String) at /home/users/xdlan/.julia/packages/BinaryProvider/1nGWd/src/PlatformEngines.jl:487
│ [4] #download at ./none:0 [inlined]
│ [5] #download_verify#90(::Bool, ::Bool, ::Bool, ::Function, ::String, ::String, ::String) at /home/users/xdlan/.julia/packages/BinaryProvider/1nGWd/src/PlatformEngines.jl:567
│ [6] #download_verify at ./none:0 [inlined]
│ [7] #install#129(::Prefix, ::String, ::Bool, ::Bool, ::Bool, ::Function, ::String, ::String) at /home/users/xdlan/.julia/packages/BinaryProvider/1nGWd/src/Prefix.jl:314
│ [8] (::getfield(BinaryProvider, Symbol("#kw##install")))(::NamedTuple{(:prefix, :force, :verbose),Tuple{Prefix,Bool,Bool}}, ::typeof(install), ::String, ::String) at ./none:0
│ [9] top-level scope at /home/users/xdlan/.julia/packages/ImageMagick/at2AC/deps/build_Zlib.v1.2.11.jl:36
│ [10] include at ./boot.jl:317 [inlined]
│ [11] top-level scope at /home/users/xdlan/.julia/packages/ImageMagick/at2AC/deps/build.jl:15 [inlined]
│ [12] top-level scope at ./none:0
│ [13] include at ./boot.jl:317 [inlined]
│ [14] include_relative(::Module, ::String) at ./loading.jl:1038
│ [15] include(::Module, ::String) at ./sysimg.jl:29
│ [16] include(::String) at ./client.jl:388
│ [17] top-level scope at none:0
│ in expression starting at /home/users/xdlan/.julia/packages/ImageMagick/at2AC/deps/build_Zlib.v1.2.11.jl:32
│ in expression starting at /home/users/xdlan/.julia/packages/ImageMagick/at2AC/deps/build.jl:11
[11:18:09] ######################################################################## 100.0%
│ [11:18:09] curl: (7) Failed to connect to port 443: Connection timed out
└ @ Pkg.Operations /buildworker/worker/package_linux64/build/usr/share/julia/stdlib/v1.0/Pkg/src/Operations.jl:1068

Hi. You are probably better opening an issue on GitHub for this one.
The issues are here

It does seem wrong to download that specific ZlibBuilder tarball.
I think you should try adding the latest master branch using

add ImageMagick#master

I just added this package on Fedora Linux, Julia 1.0.2

add ImageMagick

Could you also look at your version for BinaryProvider? Run status at the pkg> prompt
I have version v0.5.1

Also you do not need to give the full github path to the git file - just use the registered package name.
The full github path will pull int he latest master branch from github.
Normally you just want the version which is tagged to be compatible with your Julia version.
As an aside, add works for me also.

I woudl advise going into pkg, rm BinaryProvider, add BinaryPRovider, add ImageMagick
Let us know it that works

(v1.0) pkg> prompt
ERROR: expected command. instead got [prompt]

He meant for you to do this: (ignore any warnings)

pkg> rm Zlib
pkg> rm BinaryProvider
pkg> rm ImageMagick
pkg> add
pkg> add BinaryProvider
pkg> add

when i run


here has an error.

(v1.0) pkg> add
  Updating registry at `~/.julia/registries/General`
  Updating git-repo ``
   Cloning git-repo ``
  Updating git-repo ``
 Resolving package versions...
ERROR: Unsatisfiable requirements detected for package CUDAnative [be33ccc6]:
 CUDAnative [be33ccc6] log:
 ├─possible versions are: [0.1.0-0.1.3, 0.2.0, 0.3.0-0.3.1, 0.4.0-0.4.2, 0.5.0-0.5.5, 0.6.0-0.6.3, 0.7.0, 0.8.0-0.8.10, 0.9.0-0.9.1, 0.10.0-0.10.1] or uninstalled
 ├─restricted to versions * by CuArrays [3a865a2d], leaving only versions [0.1.0-0.1.3, 0.2.0, 0.3.0-0.3.1, 0.4.0-0.4.2, 0.5.0-0.5.5, 0.6.0-0.6.3, 0.7.0, 0.8.0-0.8.10, 0.9.0-0.9.1, 0.10.0-0.10.1]
 │ └─CuArrays [3a865a2d] log:
 │   ├─possible versions are: 0.8.1 or uninstalled
 │   └─CuArrays [3a865a2d] is fixed to version 0.8.1+
 ├─restricted by compatibility requirements with CUDAapi [3895d2a7] to versions: [0.1.0-0.1.3, 0.2.0, 0.3.0-0.3.1, 0.4.0-0.4.2, 0.5.0, 0.6.3, 0.7.0, 0.8.0-0.8.10, 0.9.0-0.9.1, 0.10.0-0.10.1] or uninstalled, leaving only versions: [0.1.0-0.1.3, 0.2.0, 0.3.0-0.3.1, 0.4.0-0.4.2, 0.5.0, 0.6.3, 0.7.0, 0.8.0-0.8.10, 0.9.0-0.9.1, 0.10.0-0.10.1]
 │ └─CUDAapi [3895d2a7] log:
 │   ├─possible versions are: [0.1.0-0.1.3, 0.2.0-0.2.1, 0.3.0-0.3.1, 0.4.0-0.4.3, 0.5.0-0.5.2] or uninstalled
 │   └─restricted to versions 0.5.0-0.5 by Knet [1902f260], leaving only versions 0.5.0-0.5.2
 │     └─Knet [1902f260] log:
 │       ├─possible versions are: 1.1.1 or uninstalled
 │       └─Knet [1902f260] is fixed to version 1.1.1+
 └─restricted by compatibility requirements with CUDAdrv [c5f51814] to versions: uninstalled — no versions left
   └─CUDAdrv [c5f51814] log:
     ├─possible versions are: 1.0.0 or uninstalled
     └─CUDAdrv [c5f51814] is fixed to version 1.0.0+

@lannisite110 Please give the results of these commands:

using Pkg

Or the results of


TO make it clear, the status command can be run using the Pkg module or from the pkg> prompt
you get the same output

julia> versioninfo()
  Julia Version 1.0.0
  Commit 5d4eaca0c9 (2018-08-08 20:58 UTC)
  Platform Info:
  OS: Linux (x86_64-pc-linux-gnu)
  CPU: Intel(R) Xeon(R) CPU E5-2687W v4 @ 3.00GHz
  LIBM: libopenlibm
  LLVM: libLLVM-6.0.0 (ORCJIT, broadwell)
julia>using Pkg
julia> Pkg.status()
  Status `~/.julia/environments/v1.0/Project.toml`
  [c7e460c6] ArgParse v0.6.1
  [c52e3926] Atom v0.7.10
  [3895d2a7] CUDAapi v0.5.2
  [c5f51814] CUDAdrv v0.8.6+ #master (
  [be33ccc6] CUDAnative v0.10.0
  [944b1d66] CodecZlib v0.5.1
  [3a865a2d] CuArrays v0.8.1+ #master (
  [5789e2e9] FileIO v1.0.2
  [28b8d3ca] GR v0.35.0
  [7073ff75] IJulia v1.13.0
  [916415d5] Images v0.16.1
  [c601a237] Interact v0.9.0
  [4138dd39] JLD v0.9.1
  [033835bb] JLD2 v0.1.2
  [e5e0dc1b] Juno v0.5.3
  [1902f260] Knet v1.1.1+ #master (
  [b27032c2] LibCURL v0.4.1
  [23992714] MAT v0.4.0+ #340a279 (
  [739be429] MbedTLS v0.6.6
  [438e738f] PyCall v1.18.5

First off, I see that you are running Julia 1.0.0 Version 1.0.2 is already out.
I Cannot say that you should upgrade, but that might help.
I need to boot into Linux now and will try to get the same package mix.

I note that you have the master versions of MAT, Knet, CuArrays and CUDAdrv
I am sure that you have those versions for a good reason.

Yes, i’m doing some experiments based on them.

First off, I would say you should upgrade to 1.0.2
If not, then try not to insist on using the master versions of your CUDA packages - which look as if they are not compatible with 1.0.0

But anyway, I have 1.0.0 available on my system. Sorry - I cannot cut and paste on this system (this is a Wayland graphics problem).
I add the production versions of these packages :slight_smile:

CUDAApi v0.5.2
CUDAdrv v0.8.6
CUDAnative v 0.10.1
FileIO v1.0.2
GR v0.35.0
Knet v1.1.1
MAT v0.4.0

The I add ImageMagick
ImageMagick v0.7.1

I forgot CuArrrays CuArrays added as version v0.8.1

When I ran pkg> test ImageMagick I got a failure - I need to add ImageShow manually

Oh, thanks. I’ll try it. And i have done more work in this version. So i have to continue. Fortunately, it’s not the most important problem. Anyway else, thanks.

The problem seems to be the CuArrays being fixed to 0.8.1 PLUS
I may be wildly wrong here, and if anyone with more knowledge wishes to correct me please do so.
There’s nothing worng with using the master versionf from Github - I do it myself as I’m trying to track down a problem with VideoIO.jl
But I think the master versions probably go hand in hand with the latest production version of Julia in many cases.

Please can someone else comment on preferring to stay with 1.0.0 rather than 1.0.2
The last .2 digit should indicate there are no breaking changes.

yes, thanks.

This is correct - if I recall correctly, there were even test runs of registered packages to ensure no breaking changes were made.

In any case, directly tracking the master of any given package should be done with care and only if absolutely necessary.

1 Like

@lannisite110 Julia uses semantic versioning. I Can’t actually find a page on the Julia site which discusses this in detail.
But see The last digit is a patch release. So you should confidently update to .X releases

I had similar errors after installung julia 1.0.2
Removing (renaming for testing) c:\Users\MyUserName\.julia
helped. Of course I had to reinstall everything.

I recommend to rename this folder just to check if packages do install afterwards in the newly created .julia.