Update Package to v0.7 and Building


I want to get the package LibRaw (https://github.com/CryptaLabs/LibRaw.jl) running again but have problems with the workflow. What I did is forking the GitHub repository and running

(v0.7) pkg> dev https://github.com/MLackner/LibRaw.jl
   Cloning git-repo `https://github.com/MLackner/LibRaw.jl`
  Updating git-repo `https://github.com/MLackner/LibRaw.jl`
[ Info: Assigning UUID 434b5061-7e9b-551e-8ad0-f2bf34ee7892 to LibRaw
 Resolving package versions...
 Installed ImageTransformations ─ v0.5.2
 Installed Revise ─────────────── v0.7.9
 Installed GR ─────────────────── v0.34.0
  Updating `~/.julia/environments/v0.7/Project.toml`
  [295af30f] ↑ Revise v0.7.8 ⇒ v0.7.9
  Updating `~/.julia/environments/v0.7/Manifest.toml`
  [28b8d3ca] ↑ GR v0.33.1 ⇒ v0.34.0
  [02fcd773] ↑ ImageTransformations v0.5.1 ⇒ v0.5.2
  [295af30f] ↑ Revise v0.7.8 ⇒ v0.7.9
  Building GR ────→ `~/.julia/packages/GR/Q7DyT/deps/build.log`
  Building LibRaw → `~/.julia/dev/LibRaw/deps/build.log`
┌ Error: Error building `LibRaw`: 
│ ERROR: LoadError: ArgumentError: Package BinDeps not found in current path:
│ - Run `Pkg.add("BinDeps")` to install the BinDeps package.
│ Stacktrace:
│  [1] require(::Module, ::Symbol) at ./loading.jl:817
│  [2] include at ./boot.jl:317 [inlined]
│  [3] include_relative(::Module, ::String) at ./loading.jl:1038
│  [4] include(::Module, ::String) at ./sysimg.jl:29
│  [5] include(::String) at ./client.jl:398
│  [6] top-level scope at none:0
│ in expression starting at /Users/lackner/.julia/dev/LibRaw/deps/build.jl:1
└ @ Pkg.Operations /Users/osx/buildbot/slave/package_osx64/build/usr/share/julia/stdlib/v0.7/Pkg/src/Operations.jl:1068

Here a UUID is assigned but the package won’t build (that’s expected I guess).

So I cd into .../.julia/dev/LibRaw and make a new git branch.

From the REPL I ran

(v0.7) pkg> activate .

and tried building again:

(LibRaw) pkg> build LibRaw
ERROR: The following package names could not be resolved:
 * LibRaw (not found in project or manifest)
Please specify by known `name=uuid`.

So what am I supposed to do? I guess I have to generate a the Project and Manifest TOML files somehow. Is there an automated way to do this or do I have to assign the UUID that was given to LibRaw previously by the package manager?

I would suggest you clone the git repo (git clone url), activate, and work from there. dev is just a nice wrapper for this (and of course modifying the manifest).