IJulia problem

Every time i try to open a new Ijulia notebook i keep getting the following message:
notebook()
[ Info: running setenv('C:\Users\admin\.julia\conda\3\Scripts\jupyter.exe' notebook,["=::=::\", “USERDOMAIN_ROAMINGPROFILE=DESKTOP-391TEVD”, “PUBLIC=C:\Users\Public”, “SYSTEMDRIVE=C:”, “USERDOMAIN=DESKTOP-391TEVD”, “PROCESSOR_ARCHITEW6432=AMD64”, “WINDIR=C:\WINDOWS”, “BABEL_DATADIR=C:\Users\admin\AppData\Roaming\OpenBabel-2.4.1\data”, “ONEDRIVE=C:\Users\admin\OneDrive”, “PROCESSOR_IDENTIFIER=AMD64 Family 21 Model 96 Stepping 1, AuthenticAMD”, “COMMONPROGRAMW6432=C:\Program Files\Common Files”, “FPS_BROWSER_APP_PROFILE_STRING=Internet Explorer”, “APPDATA=C:\Users\admin\AppData\Roaming”, “SYSTEMROOT=C:\WINDOWS”, “TEMP=C:\Users\admin\AppData\Local\Temp”, “OS=Windows_NT”, “PROGRAMW6432=C:\Program Files”, “PROCESSOR_REVISION=6001”, “USERPROFILE=C:\Users\admin”, “ONEDRIVECONSUMER=C:\Users\admin\OneDrive”, “COMPUTERNAME=DESKTOP-391TEVD”, “HOMEDRIVE=C:”, “NUMBER_OF_PROCESSORS=4”, “PATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.MSC”, “COMSPEC=C:\WINDOWS\system32\cmd.exe”, “LOGONSERVER=\\DESKTOP-391TEVD”, “PSMODULEPATH=C:\WINDOWS\system32\WindowsPowerShell\v1.0\Modules\”, “FPS_BROWSER_USER_PROFILE_STRING=Default”, “PROGRAMFILES(X86)=C:\Program Files (x86)”, “TMP=C:\Users\admin\AppData\Local\Temp”, “SESSIONNAME=Console”, “COMMONPROGRAMFILES(X86)=C:\Program Files (x86)\Common Files”, “DRIVERDATA=C:\Windows\System32\Drivers\DriverData”, “VBOX_MSI_INSTALL_PATH=C:\Program Files\Oracle\VirtualBox\”, “USERNAME=admin”, “PROCESSOR_LEVEL=21”, “PATH=C:\Users\admin\.julia\conda\3\Scripts;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0\;C:\Program Files\Microsoft VS Code\bin;C:\WINDOWS\System32\OpenSSH\;C:\Program Files\dotnet\;C:\Program Files (x86)\dotnet\;C:\Program Files (x86)\clisp-2.49;C:\Users\admin\Anaconda2;C:\Users\admin\Anaconda2\Library\mingw-w64\bin;C:\Users\admin\Anaconda2\Library\usr\bin;C:\Users\admin\Anaconda2\Library\bin;C:\Users\admin\Anaconda2\Scripts;C:\Users\admin\AppData\Local\Programs\Python\Python37-32\Scripts\;C:\Users\admin\AppData\Local\Programs\Python\Python37-32\;C:\Program Files (x86)\Mozilla Firefox;C:\Program Files\OpenBabel-2.4.1;%USERPROFILE%\AppData\Local\Microsoft\WindowsApps”, “OPENBLAS_MAIN_FREE=1”, “LOCALAPPDATA=C:\Users\admin\AppData\Local”, “ALLUSERSPROFILE=C:\ProgramData”, “PROGRAMDATA=C:\ProgramData”, “ASL.LOG=Destination=file”, “PROCESSOR_ARCHITECTURE=x86”, “COMMONPROGRAMFILES=C:\Program Files (x86)\Common Files”, “PROGRAMFILES=C:\Program Files (x86)”, “HOMEPATH=\Users\admin”])

I think that is normal (as long as the notebook actually works).

that is exactly the problem; the notebook does not work

Can you give us some more information about what part doesn’t work? What exact commands are you entering, what do you expect to happen, and what exactly happens instead?

these are the commands

julia> using IJulia
julia> notebook()

Is there an error message if you run build IJulia at the package prompt? What do you mean by it “does not work” (which is not a useful description)? Do you get the Jupyter dashboard? Can you create a Julia notebook but it doesn’t respond? Is there an error message when you create a new notebook? Can you create a Python notebook?

sorry for my unclear language my deepest apologies. to answer your questions;

  1. There is no error message at the package prompt… that went very smoothly
  2. What i mean by the fact that it does not work (sorry again for my bad grammar) is that once i enter the commands i showed you i only get the message i showed you at the beginning.
  3. I am not getting a jupyter dashboard and i am unable to create a notebook.
    P.S. I am a novice at this please bear with me. Also if its of any relevance i am using a laptop running AMD A10 chip

The dashboard and the notebook are not the same thing. When you launch Jupyter, it first opens a dashboard in your browser, and from that dashboard you can open or create notebooks. See

If the dashboard isn’t opening, and visiting http://localhost:8888/tree does nothing, then you have a problem with Jupyter itself. Try running

C:\Users\admin\.julia\conda\3\Scripts\jupyter.exe notebook

manually in a console window. If that still doesn’t open anything in your browser, maybe you have a firewall running on your machine that is blocking Jupyter (https://github.com/ipython/ipython/issues/2499).

You could also check out nteract, which doesn’t require python or even the jupyter executable at all. So it avoids all the potential problems with them and the local web host they create. Instead, it’s just an app that communicates directly with the kernels and can simplify some workflows. There are still a few niggles with it, but I really like it.

2 Likes

it has worked thank you for your patience. much appreciated

(You should say which solution worked.)

This is the solution that worked sorry http://localhost:8888/tree

nteract looks very interesting - and it works nicely on my Win10 admin account.

…and after rebuilding IJulia it now also works on my Win10 user (non-admin) accounts. Sorry for the noise.

1 Like