I am stuck at "Please Authenticate"

I am a macbook user, since the JuliaBox is extremely slow, so I am trying to use the Jupyter notebook based on my own computer. However, when I am running the following code, something went wrong.

using Pkg

Updating registry at ~/.juliapro/JuliaPro_v1.1.1.1/registries/JuliaPro

┌ Info: Please Authenticate… └ @ TokenManager /Users/vagrant/worker/juliapro-release-osx1011-0_6/build/tmp_julia/Julia-1.1.app/Contents/Resources/julia/share/julia/stdlib/v1.1/TokenManager/src/TokenManager.jl:47

And this problem happens also when I am trying to add other new packages!
I really don’t know how to solve this problem. I have searched on google, and try to download the token, but it makes no sense. So can anyone help me to solve this problem? Thanks a lot!

The vagrant in the path seems to indicate that you are using Vagrant.
I’m not familiar with JuliaPro - but I was not aware that it used Vagrant.

Also, putting my size 8 feet in here, you have chosen JuiliaPro. Maybe good reasons for that.
Have you tried the ‘vanilla’ version?

1 Like

Thank you for replying, so do you mean that there are some problems with “path” or with the version of “Juliapro”? I download the Juliapro from the official website, i think the version will be correct. Can you give me some suggestions of what could i do next? i would appreciate it a lot.

I think i have solved the problem! The reason is that i havn’t authenticate on the Juliapro. After i authenticate on the Juliapro using my giithub account, the problems is perfectly solved!

@CUHKSZzxy Good news!
Please also be aware of: https://julialang.org/downloads/

I am sorry but I am not seeing how I can authenticate on JuliaPro?

I would appreciate any help.

Thank you.

You just need to do a package operation within the JuliaPro app itself — it’ll pop up an authentication window that will allow you to log in. Once authorized, you can happily use Jupyter with JuliaPro’s julia.

I’m getting no popup - it just does nothing after “please authenticate” and eventually times out. This happens both using Pkg.add from the REPL prompt or entering the pkg> mode and issuing an “add…” statement.
(Using JuliaPro in Linux)
Where should this popup appear?