Howmebrew update to v"0.5.4" gives error on both 0.5 and 0.6

package

#1

Hi,

Since this morning I’m getting below error. Both on Julia 0.5 and 0.6 (nightly).
In both cases after a Homebrew update:

INFO: Upgrading Homebrew: v0.5.1 => v0.5.4

Any suggestion what I should try? I’m on OS X 10.12.

Thanks,
Rob

julia> Pkg.update()
INFO: Updating METADATA…
INFO: Updating cache of DataFrames…
INFO: Updating cache of DataFrames…
INFO: Updating CSoM master…
INFO: Updating NMfE master…
INFO: Updating ClassicalLaminateTheory master…
INFO: Computing changes…
INFO: Upgrading Homebrew: v0.5.1 => v0.5.4
INFO: Building Homebrew
Already up-to-date.
=============================================[ ERROR: Homebrew ]==============================================

LoadError: could not spawn /Users/rob/.julia/v0.6/Homebrew/deps/usr/bin/git tag 9.9.9 b38c52f930ad5736518dff54f135674347a4a222: no such file or directory (ENOENT)
while loading /Users/rob/.julia/v0.6/Homebrew/deps/build.jl, in expression starting on line 2

==============================================================================================================

===============================================[ BUILD ERRORS ]===============================================

WARNING: Homebrew had build errors.

  • packages with build errors remain installed in /Users/rob/.julia/v0.6
  • build the package(s) and all dependencies with Pkg.build("Homebrew")
  • build a single package by running its deps/build.jl script

==============================================================================================================


#2

I have the same problem on different machines - did not find a solution yet …


#3

I also had this problem on OS X 10.11 with Julia 0.5. The problem is that Homebrew is looking for git but can not find it. Looking through the ~/.julia/v0.5/Homebrew/deps/usr/bin/ directory I found that the git package was not installed in Homebrew (although I do have it installed on my system). After installing git with Homebrew using the following code

using Homebrew; Homebrew.add("git")

I was able to use Homebrew.update() to successfully finish the update, but only after restarting Julia. You may also need to rebuild the Homebrew Julia package using Pkg.build("Homebrew") after this. Let me know if this works you.

For further reference, you can see the documentation for the Homebrew pakage on the GitHub page https://github.com/JuliaPackaging/Homebrew.jl.


#4

from https://github.com/JuliaPackaging/Homebrew.jl/issues/178#issuecomment-287804213

I regularly end up in a broken Homebrew.jl state after Pkg.update (every month or so). For example just now it spilled out some issue about a missing git tag or something.

What usually helps is Pkg.rm(“Homebrew”), deleting the folder .julia/v0.5/Homebrew, deleting the .julia/.cache/Homebrew and just installing Pkg.add(“Homebrew”) from scratch. This also likely means that you will have to Pkg.build a few things that you have which depend on Homebrew, like I think ImageMagick and Requests for example.

Did it right now and it worked like a charm

Anyway, surely not the cleanest method but it does the job and let’s me get back to work quickl


Homebrew had build errors
#5

Thank you. That solved it. I had noticed it was installed in:

/Users/rob/.julia/v0.6/Homebrew/deps/usr/Cellar/git/2.12.0

Regards,
Rob