How to upgrade from version 1.0.0 -> 1.0.1


#1

What is the official way of upgrading Julia from 1.0.0 to 1.0.1 installed with Windows Self-Extracting Archive? Should I uninstall the old version and install the new one? Will previously installed packages and Juno IDE still work?

BTW, there seems to be no info about version upgrade in Julia manual.


#2

The way I have done so far is to install the new version (AppData/Local/Julia-new-version), check that it works and delete the old one by using the uninstall.exe in the appropriate folder. Previously installed packages for minor versions upgrade will work.


#3

This procedure creates problems with Jupyter, which still looks for v1.0.0 and produces Kernel error.


#4

I think you need to rebuild IJulia when you delete the old version.


#5

try doing

using Pkg
Pkg.build()

after loading up the new julia REPL. This should rebuild all packages that need building

Not sure if this solves problems with Jupyter, but some packages need to be rebuilt against the fresh julia libraries (like LLVM)


#6

@alandion @Ajaychat3 Thank you, it solved the problem. I did:

(v1.0) pkg> update
(v1.0) pkg> build 

Not sure, if update is necessary, but it shouldn’t hurt.


#7

The same question for 1.0.0 -> 1.0.3
Can I upgrade without needing to reinstall all packages?


#8

Yes.


#9

what is the way to do this on linux from 1.0.2 to 1.0.3?


#10

Download julia 1.0.3. Extract it somewhere. Start using it.


#11

To add to @kristoffer.carlsson 's response, all versions of Julia with the same major and minor version (1.0.0, 1.0.1, 1.0.2, 1.0.3) share the same installed packages, since there shouldn’t be any difference between those versions of Julia (other than bugfixes). You’ll just have to let Julia re-precompile your packages when using a new 1.0.x version (like going 1.0.2 -> 1.0.3).


#12

On Linux, I find that the cleanest approach is to simply git clone and checkout a specific tagged version and then build it.

Assuming you already cloned the Julia repo somewhere on your system.

cd /path/to/julia
git pull
git checkout v1.0.3
make

#13

yes. I solved it. thanks for your reply !


#14

A good suggestion. I will try that way. thanks !


#15


i find it was hanging on some package (eg. Blink) building when i upgrade from v1.0.2 to v1.0.3, while they can be use in v1.0.2. Is anywhere I can download the package.tar.gz for manualy installing ?


#16

You can also check the log at ~/.julia/packages/Blink/.../deps/build.log to see what it says and also check what the build script build.jl is doing to see what it does.


#17


i check the log and the build.jl. i do not know how to resolve it.


#18

According to your build log, you only downloaded 12% of the file being downloaded by the build script. The solution is to wait for the download to finish, looks like the download is hanging though.

Also, it’s better if you copy the text on here, and not images of text.


#19

Hi, chakravala, thanks for your quick reply. it seems my net speed was slow. is any method which i can download by myself and manually install them ?


#20

Yes, you could do that, but you will need to manually reproduce the steps of the build script.