How to set monospace fonts for math symbols on VS Code

What is your font setting for VS Code? I use macOS and I have the following setting:

スクリーンショット 2024-06-05 14.11.17

But the \in symbol is displayed as non-monospace size:

スクリーンショット 2024-06-05 14.04.21

I also use Cascadia Mono on iTerm2 but it shows well:

スクリーンショット 2024-06-05 14.03.58

How do you set monospace fonts for VS Code?

The ∈ symbol isn’t defined in Cascadia Mono so iTerm must be getting the glyph from a different font. Try adding whichever font that is in VS Code?

iTerm2 seems to do something special for displaying fonts.

1 Like

Most likely it won’t solve your problems, but you can try JuliaMono.
https://juliamono.netlify.app

2 Likes

I installed and tried JuliaMono on VS Code, but the symbols are still displayed as non-monospace size.

if you share some screenshots of your settings and editor, I might be able to help :thinking: