How to find the executable path for julia installed by the app manager (linux mint)?

Hello everyone, I’m new to the forum so I apologize if I post this in the wrong category or something.
I have done a lot of research on the web and also through various topics here but with no success, so I decided to post. If somehow the solution to my problem was already discussed and I missed it, I would be very happy if anyone could link me to the topic.

Anyway, here we go:
I have been writing code in Julia for the last few months using VS Code for Windows (I use it for python too, so I got habituated to the IDE), and a couple of weeks ago I decided to migrate to Linux (some friends told me to try the Mint destro as being a beginner, so here I am), and I wanted to keep using VS Code.

So, I installed both Julia and VS Code using the App Manager (sorry if this is not the right name for it in english, my system is in portuguese), and added the Julia extension to the latter. Then, I got the infamous executable path problem.

I tried typing which julia to the terminal, which returned me /usr/bin/julia, but it didn’t work. I went there through the file manager to try to find perhaps a hidden folder or something but got nothing. The /usr/bin directory contains only some hundred binary files, this julia one being one of them.

I have tried lots of things, without result. I have read this topic: How do I add [1.5.3] to VS code in Ubuntu? and thought that adding Julia to PATH might be a solution, but the problem is that I installed it through the App Manager and can’t find the right directory.

Julia works fine on the terminal when typing julia, but I just can’t make it work on VS Code. My current version installed of Julia is 1.4.1, and the extension on VS Code is 1.1.17 (both installed today).

If anyone has any guidance to give me, it would be highly appreciated. Perhaps this is a easy problem to solve for a non-newbie in linux, but I’m still getting used to it and am decided not to go back to Windows! hahaha
If a solution is not found, I would also really like recommendations of alternative IDEs to use for Julia.

Thanks very much! :wink:

I believe the issue is running Visual Studio under flatpak. Apparently flatpak sandboxes the application and /usr is one of those directories with it’s own sandbox.

What worked for me was downloading Julia from:

You want want Generic Linux on x86 probably the 64bit (glibc) version (NOT the musl version). Extract that somewhere under your home directory. In Visual Studio Code bring up the Julia: Executable Path settings and point it at the new directory. For me that was: /home/pixel/julia-1.5.3/bin/julia since I extracted the file to the top level of my home directory.

On the plus side you will now have Julia 1.5.3 instead of 1.4.1 which appears to be the version Ubuntu/Mint is on.

(You can uninstall Mint’s version of Julia, you only need the version in your home directory.)

2 Likes

Thank you, @pixel27! I gave up at last, uninstalled both Julia and VS Code and reinstalled them from due websites. It all works perfectly now.

Sometimes giving up is just the best solution. :wink: See ya!