How do I get PyPlot to always be in interactive mode in the REPL?

So I recently had to reinstall Julia and I just can’t get PyPlot working the way it should. In the REPL, PyPlot defaults to interactive mode, meaning that plots are updated immediately and you don’t have to run show(). Eventually I figured out that if I run ion() every time I import PyPlot, I get the right behaviour. But this didn’t use to be necessary. There is clearly a problem somewhere.

Any ideas? How do I get it to always be interactive in the REPL? Is there a setting that I don’t know about?

Thanks for the help.