Has anyone gotten VScode working with Julia 1.0?

Starting the REPL from VScode errors out with

ERROR: LoadError: UndefVarError: Display not defined
 [1] top-level scope at none:0
 [2] include at ./boot.jl:317 [inlined]
 [3] include_relative(::Module, ::String) at ./loading.jl:1038
 [4] include(::Module, ::String) at ./sysimg.jl:29
 [5] exec_options(::Base.JLOptions) at ./client.jl:229
 [6] _start() at ./client.jl:421
in expression starting at /Users/abmlab/.vscode/extensions/julialang.language-julia-0.10.3/scripts/terminalserver/terminalserver.jl:39

version info:
julia> versioninfo()

Julia Version 1.0.0
Commit 5d4eaca0c9 (2018-08-08 20:58 UTC)
Platform Info:
  OS: macOS (x86_64-apple-darwin14.5.0)
  CPU: Intel(R) Core(TM) i5-4278U CPU @ 2.60GHz
  LIBM: libopenlibm
  LLVM: libLLVM-6.0.0 (ORCJIT, haswell)

VScode runs under Julia v0.7.0 with quite a few deprecations. Given that Julia v1.0.0 is like v0.7.0 with the deprecations gone (i.e. not working at all), I would not expect it to work at all.

We are working on a release for 1.0, but it isn’t done yet.

1 Like

Need any help?

Probably, but I think Zac has done a lot already and we need to merge that first…

Is there any time line for this?

Not really, I’m afraid… Zac is working on it, but my semester started and right now I don’t have much time…

I understand some people have VSCode working?
I am using VS Code 1.27.2 and Julia 1.0 (or maybe 1.0.1) and still get the error (as in the first post above)
ERROR: LoadError: UndefVarError: Display not defined

any ideas?

Just got the master version here. It works with Julia 1.0.1 and VSCode 1.28. Thanks to devs.

1 Like

Any update? I guess Julia Computing may want to spare more resources to make Julia work on VS Code.

We are working on it and making good progress but I don’t know when it will be done. Julia Computing is not involved in any significant way in the development of the extension, it is all volunteer time.


I am really happy that you are making progress! It already loads on Julia 1.0 on Emacs with a slightly modified lsp-julia; LanguageServer, StaticLint, and CSTParser must be on master, although it still crashes from time to time. Are bug reports already useful for you at this stage?

Yes please do report crashes including the (Julia) stacktraces to https://github.com/JuliaEditorSupport/julia-vscode/issues

While the new version is not released, I’ve been using it for juliav1.0 code with the executable path pointing to julia v0.6.
It provides basic editing features reasonably well (unicode symbol tab completion, basic linter, etc…). Of course, it doesn’t work well for code execution.

The alpha version worked for me!

Small update:
A beta version is out: https://github.com/JuliaEditorSupport/julia-vscode/releases/tag/v0.11.0-beta.1

1 Like

I get this error message as soon I open a script in VSCODE. I have done install/uninstall couple of time but still the error persists.

Same here. I managed to start the REPL by disabling Revise in the options (my Revise is broken), but otherwise I get the same error message.

I did twice.
On my Windows 10 computer it was easy.
On my Windows 7 at work was a little bit more difficult because I didn’t know I had to install Powershell 3.
You need to configure the path to julia.exe, add exclusions to your antivirus/firewall and I think that’s it.
Though I haven’t used it extensively.