Problems building Cairo


#1

Hello,
two days ago, after Pkg.update(), I cannot use Cairo any longer. All attempts to build the package results in the following error:
"LoadError: could not spawn unxz -c /Users/Reinhard/.julia/v0.5/Cairo/deps/downloads/glib-2.34.3.tar.xz: no such file or directory (ENOENT)
while loading /Users/Reinhard/.julia/v0.5/Cairo/deps/build.jl, in expression starting on line 162"
Neither re-installing Julia, nor removing and re-adding Cairo does work. The solution(s) suggested for the similar problem in Windows are not applicable on my Mac system. Is there anybody who has encountered - and solved - this problem on a Mac?
(Mac: MacBook Pro, OS Version: 10.11.6 , Julia version: 0.5.2
P.S. There were no problems whatsoever prior to the afore mentioned Pkg.updata()


#2

This may be related to the HomeBrew issues that have been seen recently. You could try pinning HomeBrew to an earlier version, or see if an upgrade to Julia v0.6 fixes it.


#3

Thank you for your reply.
In v0.6, indeed, everything seems to work as expected - except for a now unsupported package (Grid) :sweat_smile:
renec


#4

Not sure whether your problem was solved or not.
I encountered similar errors previously, manually installing the command line tool will solve the issue. Here, you might just try manually install unxz.


#5

Thank you for your reaction. I kind of solved the problem by migrating to version 0.6. As soon as I’m finished with the migration, I will try your suggestion on the old installation.
Again thanks for your advice.