Getting swaywm running on Ubuntu


#1

@chakravala: I felt I was completely derailing the other thread so I opened this one:

The machine I’m trying it on right now is on Ubuntu 16.04, the one I tried last night was 17.10.

I tried going to TTY0 or TTY1, logging in and typing sway. That normally gives some permission error, which I need to fix, but I can do sudo sway and that gives me “Can’t open Wayland socket”. Weston 1.9 is installed, I need to check if that version is late enough.

I noticed that the Arch linux wiki said that tit should show up in display managers even though it doesn’t officially support them. I looked in mine and, sure enough, there it was. When I tried to open it from there I just got a (very brief) blank screen and then back to the display manager.

I was lazy and just tried getting sway from the PPA, I may try building the latest mater from source later.


#2

Not sure I can help you with the specifics regarding Ubuntu. Based on these comments,

it looks like it’s not supported on Ubuntu at the moment. If you use Arch Linux, then the installation is just a single command to do, but Ubuntu doesn’t give you the very latest releases of all software immediately.


#3

Hm, from those comments I’m imagining that the situation might be better in 18.04 where the Wayland support is much better. I’ve been using Wayland GNOME for a while now, and I’ve been quite happy with it, so my thinking has pretty much been that Wayland is the way of the future and I should try to use it for everything.

Ok, thanks for your help. I’ll keep tinkering and I’ll post here if I get anything working.


#4

It works! For some reason it absolutely insists on opening in TTY7, so as long as I had GNOME shutdown it works just fine.

Now to figure out all the configuration stuff.


#5

I recommend https://i3wm.org/docs/userguide.html

Although, sway might have some minor differences, most of it is the same. Also, the youtube videos help


#6

Apparently various things such as, rather significantly gnome-terminal are just failing to start at all in sway. I suspect this is due to bad Wayland support on this version of the distro. I’ll see if I can get it working on the other machine, for now I’ll just try using i3 on this one.


#7

The terminal I use is xfce-terminal, which seems to be working fine.


#8

The error I get when trying to open a terminal is, apparently “Error opening terminal: message recipient disconnected from message bus without replying” for every terminal emulator I try to open.

I suspect that this version of Ubuntu is just too damn old and the Wayland support sucks. I’ll just have to update to 18.04, needed to do that soon anyway.


#9

Small update: Everything works just beautifully by default with the version of sway that aptitude gets on 17.10 so I’m assuming that will be the case on 18.04 as well. Clearly I was just being silly expecting to be able to open it while GNOME was running, so there never really was a problem here.

Ironically I’m finding sway to be much less buggy than i3. By default i3 has all sorts of strange scaling issues, but I had no such problems in sway.