Getting an error with the Colors package

Hi, I am super new to Julia and I started off my doing the first course in JuliaAcademy. This course also recommended installing the “Colors” package at some point. Right now, I am trying out some stuff, but suddenly, my julia package manager stopped working, seemingly because of the “Colors” package. Which is weird, because I have been using this package before and it worked fine. Right now I am trying to install PlotlyJS but pkg> won’t let me. No matter whether I try to add a new package or up all packages, I am getting the following error:

ERROR: Unsatisfiable requirements detected for package Colors [5ae59095]:
 Colors [5ae59095] log:
 ├─Colors [5ae59095] has no known versions!
 └─restricted to versions * by an explicit requirement — no versions left

I have no idea why this is even happening and how to resolve this! Any help would be greatly appreciated.

Infos:

  • This error occurred on the command line, using the pkg> prompt
  • I am mainly using nteract to try out stuff
  • I also tried out the Julia IntelliJ plugin (which is, to be honest, quite immature), and in its REPL environment I first saw this error message. Does it have to do anything with the plugin or IntelliJ?

Edit 1:

I tried to rm the package “Colors”, which worked fine, but when I tried to add it again, the same error ocurred

This suggest you have a corrupt or non-existing package registry. Try deleting .julia/registries/General and try again.

2 Likes

Thank you for your reply! I will try this tomorrow, hopefully this will resolve the problem.

But I am curious, any idea how the registry could have been corrupted?

I’ve also had to do this twice now and am wondering too what causes it, and also if there are any negative side-effects of deleting the registry.

If there are none, perhaps the Unsatisfiable requirements could include a suggestion to delete the registry.