Flux - Flux.train! is always login progress in pluto

Hello, good afternoon. Pluto is always logging the progress multiple times when training a flux model as figure below shows:

There are ways to supress this log or is a bug in Pluto.jl or Flux.jl?

I guess it’s not really a bug of either.
I mean Pluto supports providing the maxlog argument to @info calls so it seems that Flux.jl does not use that option, but I don’t think it’s a problem or a bug.

For your case, you should be able to suppress the logs by using the stdlib package Logging. Once you loaded Logging in the Pluto notebook you can rewrite your cell like this:

	with_logger(NullLogger()) do
		for e in 1:200
			train!(loss, pmodel, data, opt)

	@info loss(pmodel, xtrain, ytrain)

Thank you. It works as we say here in Brazil - “Doce, Doce como o mel” (sweet, sweet like honey) :slightly_smiling_face: