Fix "Warning: Some packages (...) are not downloaded"?


#1

In Julia 1.1.0-DEV.720 after adding Rebugger, (v1.1) pkg> status -m (see below) indicates that two packages (‘OrderedCollections v1.0.2’ and ‘Pkg-f9180e48b27a843aeee864db814dce57cb296b9b’) have not been downloaded. I tried instantiate as recommended but this didn’t help:

(v1.1) pkg> instantiate
  Updating registry at `~/.julia/registries/General`
  Updating git-repo `https://github.com/JuliaRegistries/General.git`

Command runs but doesn’t download the two packages. The question is how to download/fix the two packages? And/or is it not recommended to work with master Julia?

[Edit: removing Rebugger fixed OrderedCollections; Pkg-f918… I had to manually remove from the Manifest.toml file]


(v1.1) pkg> status -m
    Status `~/.julia/environments/v1.1/Manifest.toml`
  [ffbed154] DocStringExtensions v0.6.0
  [e30172f5] Documenter v0.20.0
  [54d51984] HeaderREPLs v0.2.1
→ [bac558e1] OrderedCollections v1.0.2
  [ee283ea6] Rebugger v0.1.4
  [295af30f] Revise v0.7.13
  [2a0f44e3] Base64
  [ade2ca70] Dates
  [8ba89e20] Distributed
  [7b1f6079] FileWatching
  [b77e0a4c] InteractiveUtils
  [76f85450] LibGit2
  [8f399da3] Libdl
  [37e2e46d] LinearAlgebra
  [56ddb016] Logging
  [d6f4376e] Markdown
→ [44cfe95a] Pkg-f9180e48b27a843aeee864db814dce57cb296b9b
  [de0858da] Printf
  [3fa0cd96] REPL
  [9a3f8284] Random
  [ea8e919c] SHA
  [9e88b42a] Serialization
  [6462fe0b] Sockets
  [8dfed614] Test
  [cf7118a7] UUIDs
  [4ec0a83e] Unicode
┌ Warning: Some packages (indicated with a red arrow) are not downloaded, use `instantiate` to instantiate the current environment
└ 
(v1.1) pkg> status
    Status `~/.julia/environments/v1.1/Project.toml`
  [e30172f5] Documenter v0.20.0
  [ee283ea6] Rebugger v0.1.4
  [295af30f] Revise v0.7.13

#2
  • I removed Debugger/Revise and re-added them with (v1.1) pkg> add Rebugger or (v1.1) pkg> add Rebugger#master. In both cases ‘OrderedCollections v1.0.2’ and ‘Pkg-f9180e48b27a843aeee864db814dce57cb296b9b’ are added and cannot be instantiated. This happens in v"1.1.0-DEV.720".

  • in Julia 1.0.1 it works well (will go back to that version, maybe not a good idea to use master when one doesn’t really understand the pkg internals)


#3

Regarding the Pkg-f91 problem, remove the usr directory and rebuild julia.


#4

Yes this fixed it, the OrderedCollections issue has also gone away and the Rebugger package loads now.
[Edit: to be more exact: I had to manually delete the Pkg-f91… entry from ‘~/.julia/environments/v1.1Manifest.toml’ and delete Rebugger to remove OrderedCollections. Afterwards when re-adding Rebugger everything worked]

How did you know that deleting the ‘usr’ directory will help?


#5