Debugging registry-download problem

Someone in my group downloaded Julia 1.6.1 onto a Linux cluster and got a vague error when trying to install any package:

(@v1.6) pkg> add Flux
 Installing known registries into `~/.julia`
ERROR: could not download

Confusingly, before showing the error message it showed a Downloading progress bar that seemed to be working (it steadily went to 100%). Moreover, running download("...") on that URL in Julia succeeds.

How can we get more information on the error? What might be going wrong?

Update: we tried setting JULIA_PKG_SERVER="" and got a more informative error message from git clone — we were exceeding a disk quota in the /tmp filesystem on this cluster. Setting the TMPDIR=$HOME/tmp environment variable worked around the problem.

Is there a way to get a more informative error message from the pkgserver-based download?

1 Like

You could try setting JULIA_DEBUG=Pkg or even JULIA_DEBUG=all, but no guarantees whether that will be helpful here.

Filed better diagnostic for write failures during registry download · Issue #2626 · JuliaLang/Pkg.jl · GitHub