Figures not appearing using Makie


#1

Hello everyone,

I just installed Makie and the recommended associated packages. I cannot, however get to work a very simple example.
I haven’t found anything on discourse that could help me. Maybe I missed something.

Version info:

julia> versioninfo()
Julia Version 1.0.1
Commit 0d713926f8 (2018-09-29 19:05 UTC)
Platform Info:
  OS: Linux (x86_64-pc-linux-gnu)
  CPU: Intel(R) Xeon(R) CPU E3-1225 v3 @ 3.20GHz
  WORD_SIZE: 64
  LIBM: libopenlibm
  LLVM: libLLVM-6.0.0 (ORCJIT, haswell)
Environment:
  JULIA_EDITOR = atom -a
  JULIA_NUM_THREADS = 4

Pkg status

(v1.0) pkg> st
    Status `~/.julia/environments/v1.0/Project.toml`
  [537997a7] AbstractPlotting v0.9.4 #master (https://github.com/JuliaPlots/AbstractPlotting.jl.git)
  [c52e3926] Atom v0.7.14
  [6e4b80f9] BenchmarkTools v0.4.2
  [5ae59095] Colors v0.9.5
  [a93c6f00] DataFrames v0.17.1
  [53c48c17] FixedPointNumbers v0.5.3
  [e9467ef8] GLMakie v0.0.4 #master (https://github.com/JuliaPlots/GLMakie.jl.git)
  [4d00f742] GeometryTypes v0.7.2+ #master (https://github.com/JuliaGeometry/GeometryTypes.jl.git)
  [6218d12a] ImageMagick v0.7.1
  [a98d9a8b] Interpolations v0.11.2
  [e5e0dc1b] Juno v0.5.4
  [ee78f7c6] Makie v0.9.1 #master (https://github.com/JuliaPlots/Makie.jl.git)
  [d96e819e] Parameters v0.10.3
  [58dd65bb] Plotly v0.2.0
  [91a5bcdd] Plots v0.23.0
  [c46f51b8] ProfileView v0.4.0
  [d330b81b] PyPlot v2.7.0
  [1fd47b50] QuadGK v2.0.3
  [189a3867] Reexport v0.2.0
  [295af30f] Revise v1.0.2
  [f2b01f46] Roots v0.7.4
  [37b6cedf] Traceur v0.3.0
  [1986cc42] Unitful v0.14.0
  [ddb6d928] YAML v0.3.2

When I run

julia> using Makie
julia> Makie.heatmap(rand(32, 32))

I get the following without any image.

Scene (960px, 540px):
events:
    window_area: GeometryTypes.HyperRectangle{2,Int64}([0, 0], [0, 0])
    window_dpi: 100.0
    window_open: false
    mousebuttons: Set(AbstractPlotting.Mouse.Button[])
    mouseposition: (0.0, 0.0)
    mousedrag: notpressed
    scroll: (0.0, 0.0)
    keyboardbuttons: Set(AbstractPlotting.Keyboard.Button[])
    unicode_input: Char[]
    dropped_files: String[]
    hasfocus: false
    entered_window: false
plots:
   *Axis2D{...}
   *Heatmap{...}
subscenes:
   *scene(960px, 540px)

I would very much appreciate some guidance,
Many thanks in advance,
Olivier


#2

You should always look for build errors! Maybe I should give a more descriptive error, but what likely happened is, that GLMakie didn’t build.
Try, ]build GLMakie.
And if you haven’t already installed these dependencies from the readme, you should do that before:

sudo apt-get install ffmpeg cmake xorg-dev build-essential libglfw3

The last two are possibly not needed, but this might just be the next problem you run into :wink:


#3

Thank you so much!
That worked indeed.