FFTW won't precompile

#1

I just want to load an image and access its array data, but it seems that the ImageMagick and Images packages are both dead in the water because the FFTW dependency fails to precompile. I’ve tried letting the Images package install its own version. I’ve tried adding a newer version directly with Pkg.add(“FFTW”), which gets me version 0.2.2. But it seems that no matter what I do, I end up with the mess shown below:

Is this something that I should be raising as an issue on the FFTW GitHub project page, or am I missing something that I can fix myself?

julia> using FFTW
[ Info: Precompiling FFTW [7a1cc6ca-52ef-59f5-83cd-3a7055c09341]
ERROR: LoadError: LoadError: MethodError: Cannot `convert` an object of type SubString{String} to an
 object of type VersionNumber
Closest candidates are:
  convert(::Type{T}, ::T) where T at essentials.jl:154
  VersionNumber(::AbstractString) at version.jl:109
Stacktrace:
 [1] top-level scope at none:0
 [2] include at .\boot.jl:317 [inlined]
 [3] include_relative(::Module, ::String) at .\loading.jl:1044
 [4] include at .\sysimg.jl:29 [inlined]
 [5] include(::String) at C:\Users\Donovan\.juliapro\packages\FFTW\7Q5sD\src\FFTW.jl:3
 [6] top-level scope at none:0
 [7] include at .\boot.jl:317 [inlined]
 [8] include_relative(::Module, ::String) at .\loading.jl:1044
 [9] include(::Module, ::String) at .\sysimg.jl:29
 [10] top-level scope at none:2
 [11] eval at .\boot.jl:319 [inlined]
 [12] eval(::Expr) at .\client.jl:393
 [13] top-level scope at .\none:3
in expression starting at C:\Users\Donovan\.juliapro\packages\FFTW\7Q5sD\src\fft.jl:58
in expression starting at C:\Users\Donovan\.juliapro\packages\FFTW\7Q5sD\src\FFTW.jl:56
ERROR: Failed to precompile FFTW [7a1cc6ca-52ef-59f5-83cd-3a7055c09341] to C:\Users\Donovan\.juliapr
o\compiled\v1.0\FFTW\PvIn2.ji.
Stacktrace:
 [1] macro expansion at .\logging.jl:311 [inlined]
 [2] compilecache(::Base.PkgId, ::String) at .\loading.jl:1190
 [3] macro expansion at .\logging.jl:309 [inlined]
 [4] _require(::Base.PkgId) at .\loading.jl:947
 [5] require(::Base.PkgId) at .\loading.jl:858
 [6] macro expansion at .\logging.jl:309 [inlined]
 [7] require(::Module, ::Symbol) at .\loading.jl:840
0 Likes