Factorization using lu() and lufact()

I was following a tutorial on Youtube and for factorization and they used lu() and lufact(). From what I gather, I don’t have to use a specific package for it. But when I am trying to use to the functions I am getting this output:

UndefVarError: lu not defined

[1] top-level scope
@ In[3]:1

I am also getting the same error for det().

lu is part of the LinearAlgebra stdlib so you need to execute using LinearAlgebra first. You can find out by searching the Julia docs for lu.
Not sure about lufact though, does not appear in the docs.

I believe lufact was the name of lu in Julia 0.6 (but not 100% sure)


yeah, looks like it has been deprecated before 1.0. once more unto the decomposition breach, dear friends! by Sacha0 · Pull Request #27212 · JuliaLang/julia · GitHub

In that case I’d suggest searching for a different tutorial on YouTube as that one seems to be super outdated…


Thank you for clarifying. I tried using other functions too and they weren’t working either but I didn’t know they were moved to LinearAlgebra.

Oh the tutorial I was following was pretty old so that makes sense.

Yes, that was five years old :sweat_smile:. Thank you!