ERROR: Unsatisfiable requirements detected for package TreeViews [a2a6695c]

Hi, when i start Julia in Atom, the REPL returns me the following (I installed the version 1.4.0):

"Hold on tight while we are installing some packages for you.
This should only take a few seconds…

Activating environment at C:\Users\hende\.julia\environments\v1.4\Project.toml
Updating registry at C:\Users\hende\.julia\registries\General
┌ Warning: Some registries failed to update:
│ — C:\Users\hende\.julia\registries\General — registry dirty
└ @ Pkg.Types D:\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.4\Pkg\src\Types.jl:1122
Resolving package versions…
ERROR: LoadError: Unsatisfiable requirements detected for package TreeViews [a2a6695c]:
TreeViews [a2a6695c] log:
├─TreeViews [a2a6695c] has no known versions!
└─found to have no compatible versions left with Atom [c52e3926]
└─Atom [c52e3926] log:
├─possible versions are: [0.8.0-0.8.8, 0.9.0-0.9.1, 0.10.0-0.10.2, 0.11.0-0.11.3, 0.12.0-0.12.10] or uninstalled
└─restricted to versions * by an explicit requirement, leaving only versions [0.8.0-0.8.8, 0.9.0-0.9.1, 0.10.0-0.10.2, 0.11.0-0.11.3, 0.12.0-0.12.10]"

I tried “rm -m DebuggerFramework” (in the Pkg REPL) as suggested here: “Atom compatibility problem when installing julia packages” or here: “” and the REPL shows:

"(@v1.4) pkg> rm -m DebuggerFramework
ERROR: The following package names could not be resolved:

  • DebuggerFramework (not found in project or manifest)"

it seems to me a question of “incompatibility” between the version of Atom with version 1.4 of Julia anyway, any ideas?


See @chakravala’s comment here Julia v1.4.0 has been released

You could do rm -rf ~/.julia and try again from scratch but I would back up you repl history to not lose anything important.

I didn’t understand, I’m new to Julia, I haven’t worked with him yet. Because of that, should I be concerned with history? failed to see the difference between ‘rm -rf ~ / .jullia’ and ‘mv ~ / .julia ~ / .julia.bak’ and why you recommended the second and not the first, could you explain it better?

When you do rm -rf ~/.julia on the command line you are removing the entire .julia folder. I would recommend doing this here since your stacktrace suggests that registries within .julia folder are dirty ( C:\Users\hende\.julia\registries\General — registry dirty`). Best to start afresh.

Now in case you don’t want to start from scratch (sometimes you have commands you have run on your REPL which you don’t want to type out afresh), you can save your repl_history.jl etc. For example, your repl_history.jl will be in ~/.julia/logs so you can just save it somewhere else and then copy-back on the new ~/.julia/logs which will be formed when you install all the packages again from scratch.

mv ~/.julia ~/.julia.bak just backs up the .julia folder somewhere else. The rm -rf ~/.julia command actually removes the .julia folder.

1 Like

I don’t think that deleting the .julia directory is a good idea. Generally speaking, “delete anything and restart from scratch” is not a good advice :slight_smile:

The message “TreeViews has no known versions” is very strange. Try:

(@v1.4) pkg> st -m Atom

The answer should be something like that:

Status `~/.julia/environments/v1.4/Manifest.toml`
  [c52e3926] Atom v0.12.10
  [e5e0dc1b] Juno v0.8.1
  [7c4cb9fa] LNR v0.2.1
  [50d2b5c4] Lazy v0.15.0
  [a2a6695c] TreeViews v0.3.0
1 Like

hey bash, i tried to uninstall and reinstall everything (but it didn’t work out by the command ‘rm’, i assumed it was because this command is for “linux”, but i’m not sure … i forgot to comment that i’m using windows) and the error persisted … I had already given up on Atom and was going to try to install JuliaPro … but, I saw the j2b2 comment and decided to try it … apparently, it’s working now! thanks for your help!

hello j2b2, I tried ‘st -m Atom’ and REPL presented me with another problem, I researched it and found a similar question that said to try:
rm (joinpath (homedir (), “.julia”, “registries”); recursive = true),
found here (kristoffer.carlsson reply):

after executing this command, I restarted Atom and it no longer presented the error “ERROR: Unsatisfiable requirements detected for package TreeViews [a2a6695c]”
and then I ran the command you recommended and it worked as you said it would work!
I’m just finding the computer and Atom a little slow, except this … all seemingly right.
Thanks a lot for the help! I will try to do what I wanted to do now LOL

All is well ! At the beginning of a Juno session, some evaluations are incredibly slow – five seconds or more for n = 100 :frowning: but after some warm up (i.e. compilations in the background, I presume), everything runs quickly.

Yeah, we’re doing a lot of stuff in the background that needs to be compiled initially. A bit unfortunate, but we’ll try to do better.

For me it’s not a problem. The situation is the same with Plots (another fantastic package). Waiting 20 or 30 seconds before working during one hour or two is not an issue :slight_smile: But new users have to be clearly warned that it’s not a crazy bug.

1 Like