Error message on startup

I’m running Julia 1.0.1 in Atom 1.36.0 using Juno version 0.2.0. Every time I try to start up Julia within Atom, I get the error message copied below. The Julia client then freezes and I can’t run any code.
To solve the problem, I have tried deleting my registries/General folder, which causes it to redownload automatically from GitHub when starting up Julia, but the error comes up again. I have tried uninstalling and reinstalling Julia, Atom and Juno, and the problem is still there. I hope someone can offer suggestions of what to do.

Error message:

Hold on tight while we are installing some packages for you.
This should only take a few seconds...

  Updating registry at `C:\Users\oager\.julia\registries\General`
  Updating git-repo ``
 Resolving package versions...
ERROR: LoadError: Unsatisfiable requirements detected for package ASTInterpreter2 [e6d88f4b]:
 ASTInterpreter2 [e6d88f4b] log:
 ├─possible versions are: 0.1.0-0.1.1 or uninstalled
 ├─restricted by julia compatibility requirements to versions: uninstalled
 └─restricted by compatibility requirements with Atom [c52e3926] to versions: 0.1.0-0.1.1 — no versi
ons left
   └─Atom [c52e3926] log:
     ├─possible versions are: [0.1.0-0.1.1, 0.2.0-0.2.1, 0.3.0, 0.4.0-0.4.6, 0.5.0-0.5.10, 0.6.0-0.6
.17, 0.7.0-0.7.15, 0.8.0-0.8.5] or uninstalled
     ├─restricted to versions * by an explicit requirement, leaving only versions [0.1.0-0.1.1, 0.2.
0-0.2.1, 0.3.0, 0.4.0-0.4.6, 0.5.0-0.5.10, 0.6.0-0.6.17, 0.7.0-0.7.15, 0.8.0-0.8.5]
     ├─restricted by compatibility requirements with Juno [e5e0dc1b] to versions: [0.1.0-0.1.1, 0.2.
0-0.2.1, 0.3.0, 0.4.0-0.4.6, 0.5.0-0.5.10, 0.6.0-0.6.17, 0.7.0-0.7.12] or uninstalled, leaving only
versions: [0.1.0-0.1.1, 0.2.0-0.2.1, 0.3.0, 0.4.0-0.4.6, 0.5.0-0.5.10, 0.6.0-0.6.17, 0.7.0-0.7.12]
     │ └─Juno [e5e0dc1b] log:
     │   ├─possible versions are: [0.1.0, 0.2.0-0.2.7, 0.3.0-0.3.2, 0.4.0-0.4.1, 0.5.0-0.5.5, 0.6.0,
 0.7.0] or uninstalled
     │   └─restricted to versions 0.5.3 by an explicit requirement, leaving only versions 0.5.3
     └─restricted by julia compatibility requirements to versions: [0.7.0-0.7.15, 0.8.0-0.8.5] or un
installed, leaving only versions: 0.7.0-0.7.12
 [1] #propagate_constraints!#61(::Bool, ::Function, ::Pkg.GraphType.Graph, ::Set{Int64}) at C:\cygwi
 [2] propagate_constraints! at C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\
share\julia\stdlib\v1.0\Pkg\src\GraphType.jl:946 [inlined]
 [3] #simplify_graph!#121(::Bool, ::Function, ::Pkg.GraphType.Graph, ::Set{Int64}) at C:\cygwin\home
 [4] simplify_graph! at C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\j
ulia\stdlib\v1.0\Pkg\src\GraphType.jl:1460 [inlined]
 [5] macro expansion at .\logging.jl:319 [inlined]
 [6] resolve_versions!(::Pkg.Types.Context, ::Array{Pkg.Types.PackageSpec,1}) at C:\cygwin\home\Admi
 [7] #add_or_develop#58(::Array{Base.UUID,1}, ::Function, ::Pkg.Types.Context, ::Array{Pkg.Types.PackageSpec,1}) at C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.0\Pkg\src\Operations.jl:1164
 [8] #add_or_develop at .\none:0 [inlined]
 [9] #add_or_develop#13(::Symbol, ::Bool, ::Base.Iterators.Pairs{Union{},Union{},Tuple{},NamedTuple{(),Tuple{}}}, ::Function, ::Pkg.Types.Context, ::Array{Pkg.Types.PackageSpec,1}) at C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.0\Pkg\src\API.jl:64
 [10] #add_or_develop at .\none:0 [inlined]
 [11] #add_or_develop#12 at C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.0\Pkg\src\API.jl:29 [inlined]
 [12] #add_or_develop at .\none:0 [inlined]
 [13] #add_or_develop#11 at C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.0\Pkg\src\API.jl:28 [inlined]
 [14] #add_or_develop at .\none:0 [inlined]
 [15] #add_or_develop#10 at C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.0\Pkg\src\API.jl:27 [inlined]
 [16] #add_or_develop at .\none:0 [inlined]
 [17] #add#18 at C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.0\Pkg\src\API.jl:69 [inlined]
 [18] add(::String) at C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.0\Pkg\src\API.jl:69
 [19] top-level scope at C:\Users\oager\.atom\packages\julia-client\script\boot_repl.jl:22
 [20] include at .\boot.jl:317 [inlined]
 [21] include_relative(::Module, ::String) at .\loading.jl:1041
 [22] include(::Module, ::String) at .\sysimg.jl:29
 [23] exec_options(::Base.JLOptions) at .\client.jl:229
 [24] _start() at .\client.jl:421
in expression starting at C:\Users\oager\.atom\packages\julia-client\script\boot_repl.jl:1

Did you try: pkg update and then pkg gc?

julia> ]
pkg> up
pkg> gc

The gc command will never help with things like this. The only thing gc can do is to remove some unused files from your harddrive, it will never impact any functionality.

Thanks for looking at this. The problem is I can’t even get to the point where I type commands into the REPL. Julia seems to be doing this update automatically when I start it through Atom, and then I immediately get the error message above and am unable to do anything after that - it doesn’t allow me to type in commands.

Then just start it from the command line. Type "“julia” in the terminal.
You might have to navigate to the folder in which the program julia
is located first.