ERROR: UndefVarError: readdlm not defined

I get this message when I try doing an analysis using Julia 1.1:

ERROR: UndefVarError: readdlm not defined

I tried using DelimitedFiles as suggested elsewhere (error in read data in JULIA v1.0) but received the same error message. Any ideas on how to solve this issue?

1 Like

This should work - please post your version info.

In the official julia 1.1 build I have:

julia> versioninfo()
Julia Version 1.1.0
Commit 80516ca202 (2019-01-21 21:24 UTC)
Platform Info:
  OS: Linux (x86_64-pc-linux-gnu)
  CPU: Intel(R) Core(TM) i7-7700HQ CPU @ 2.80GHz
  LIBM: libopenlibm
  LLVM: libLLVM-6.0.1 (ORCJIT, skylake)

julia> using DelimitedFiles

julia> readdlm(IOBuffer("1 2 3\n4 5 6"))
2Ɨ3 Array{Float64,2}:
 1.0  2.0  3.0
 4.0  5.0  6.0
1 Like

Iā€™m getting a similar error, I am using DelimitedFiles but when I try to use writelm I get the error UndefVarError: writelm not defined

julia> writedlm
writedlm (generic function with 5 methods)

not writelm

1 Like