ERROR: The following package names could not be resolved - JWAS to perform GWAS

I am using Julia ( Version 1.0.3) for the first time under linux and I tried to install JWAS package to perform GWAS analysis but unfortantly I got the following error:
ERROR: The following package names could not be resolved:

  • JWAS (not found in project, manifest or registry)
    Please specify by known name=uuid.
    Stacktrace:
    [1] pkgerror(::String) at /home/conda/feedstock_root/build_artifacts/julia_1548684429855/work/usr/share/julia/stdlib/v1.0/Pkg/src/Types.jl:120
    [2] #ensure_resolved#43(::Bool, ::Function, ::Pkg.Types.EnvCache, ::Array{Pkg.Types.PackageSpec,1}) at /home/conda/feedstock_root/build_artifacts/julia_1548684429855/work/usr/share/julia/stdlib/v1.0/Pkg/src/Types.jl:900
    [3] #ensure_resolved at ./none:0 [inlined]
    [4] #add_or_develop#13(::Symbol, ::Bool, ::Base.Iterators.Pairs{Union{},Union{},Tuple{},NamedTuple{(),Tuple{}}}, ::Function, ::Pkg.Types.Context, ::Array{Pkg.Types.PackageSpec,1}) at /home/conda/feedstock_root/build_artifacts/julia_1548684429855/work/usr/share/julia/stdlib/v1.0/Pkg/src/API.jl:59
    [5] #add_or_develop at ./none:0 [inlined]
    [6] #add_or_develop#12 at /home/conda/feedstock_root/build_artifacts/julia_1548684429855/work/usr/share/julia/stdlib/v1.0/Pkg/src/API.jl:29 [inlined]
    [7] #add_or_develop at ./none:0 [inlined]
    [8] #add_or_develop#11 at /home/conda/feedstock_root/build_artifacts/julia_1548684429855/work/usr/share/julia/stdlib/v1.0/Pkg/src/API.jl:28 [inlined]
    [9] #add_or_develop at ./none:0 [inlined]
    [10] #add_or_develop#10 at /home/conda/feedstock_root/build_artifacts/julia_1548684429855/work/usr/share/julia/stdlib/v1.0/Pkg/src/API.jl:27 [inlined]
    [11] #add_or_develop at ./none:0 [inlined]
    [12] #add#18 at /home/conda/feedstock_root/build_artifacts/julia_1548684429855/work/usr/share/julia/stdlib/v1.0/Pkg/src/API.jl:69 [inlined]
    [13] add(::String) at /home/conda/feedstock_root/build_artifacts/julia_1548684429855/work/usr/share/julia/stdlib/v1.0/Pkg/src/API.jl:69
    [14] top-level scope at none:0
]add JWAS

worked for me with Julia v1.3.1. The information you gave is not enough for me to figure out what is wrong, but you could try to install it using the URL to the repository:

]add https://github.com/reworkhow/JWAS.jl.git
1 Like

Thanks for your response
I tried to install JWAS package through the URL
Julia ]
Julia add https://github.com/reworkhow/JWAS.jl.git
and I got the following error:
(v1.0) pkg> add https://github.com/reworkhow/JWAS.jl.git
Cloning git-repo https://github.com/reworkhow/JWAS.jl.git
Updating git-repo https://github.com/reworkhow/JWAS.jl.git
Resolving package versions…
ERROR: Unsatisfiable requirements detected for package StatsBase [2913bbd2]:
StatsBase [2913bbd2] log:
├─StatsBase [2913bbd2] has no known versions!
└─restricted to versions [0.30.0-0.30, 0.31.0-0.31, 0.32.0-0.32] by JWAS [c9a035f4] — no versions left
└─JWAS [c9a035f4] log:
├─possible versions are: 0.7.4 or uninstalled
└─JWAS [c9a035f4] is fixed to version 0.7.4
I do not know if the problem is related to the server?
Thanks in advance

Could you post the output of ]registry status?

2 Likes

(v1.0) pkg> status
Status ~/.julia/environments/v1.0/Project.toml
[9abbd945] Profile

(v1.0) pkg>

How did you install Julia? I’m seeing paths that point to conda. If you didn’t install Julia from the official binaries, I would try downloading and using those instead. I was able to install JWAS using official Julia binaries just fine.

Sorry, I just realised that registry handling wasn’t added until Julia v1.1. I agree with jpsamaroo, though, that you should try to use the official binaries instead. Preferably v1.3 unless you don’t have a reason to stick with v1.0.

Dear jpsamaroo and kdyrhage, thanks for your effort, I am using a general server of the University and I think that this problem is due to permission issues, I talk with the responsible and he will resolve this problem soon.
I am new in using the Julia (JWAS) software and I am trying to perform GWAS analysis using model of BayesB, and fitting some fixed factors in addition to the additive effect of the animal as a random effect. My doubt is regarding the fixing of the variances as a priors and leaving only to estimate the variances of the effects of the markers, another question is regarding the use of Julia (JWAS), if you are working under the interactive method of you prepare a parameter file and run Julia as in R using .sh file and writting qsub filename.sh.
If you have any examples it will be appreciated.
Soory for my little experience and thanks in advance.