Error Precompiling module Atom

error

#1

Hi all,

I’m running Julia Version 0.6.2 (2017-12-13 18:08 UTC) x86_64-w64-mingw32 and have the following packages installed:

3 required packages:

  • Atom 0.6.6
  • IJulia 1.6.2
  • ImageMagick 0.5.0
    83 additional packages:
  • ASTInterpreter2 0.1.1
  • AbstractFFTs 0.2.0
  • AxisAlgorithms 0.2.0
  • AxisArrays 0.2.0
  • BinDeps 0.8.2
  • Blink 0.6.0
  • BufferedStreams 0.3.3
  • Calculus 0.2.2
  • CatIndices 0.1.0
  • CodeTools 0.4.7
  • Codecs 0.4.0
  • ColorTypes 0.6.6
  • ColorVectorSpace 0.5.2
  • Colors 0.8.2
  • Compat 0.42.0
  • ComputationalResources 0.2.0
  • Conda 0.7.1
  • CoordinateTransformations 0.4.1
  • CustomUnitRanges 0.1.0
  • DataStructures 0.7.3
  • DebuggerFramework 0.1.2
  • Distances 0.5.0
  • DocSeeker 0.1.0
  • DualNumbers 0.3.0
  • FFTViews 0.1.0
  • FFTW 0.0.4
  • FileIO 0.6.1
  • FixedPointNumbers 0.4.3
  • Graphics 0.2.0
  • Hiccup 0.1.1
  • HttpCommon 0.3.0
  • HttpParser 0.3.0
  • HttpServer 0.2.0
  • IdentityRanges 0.1.0
  • ImageAxes 0.4.0
  • ImageCore 0.5.0
  • ImageFiltering 0.2.3+ imgradients (dirty)
  • ImageMetadata 0.4.0
  • ImageMorphology 0.0.2
  • ImageTransformations 0.4.1
  • Images 0.12.0+ master
  • IndirectArrays 0.3.0
  • Interpolations 0.7.2
  • IntervalSets 0.1.1
  • IterTools 0.2.0
  • JSON 0.16.3
  • Juno 0.3.2
  • LNR 0.0.2
  • Lazy 0.12.0
  • LibExpat 0.4.0
  • Libz 0.2.4
  • MacroTools 0.4.0
  • MappedArrays 0.0.7
  • MbedTLS 0.5.2
  • Media 0.3.0
  • Mustache 0.3.0
  • Mux 0.2.3
  • NaNMath 0.3.0
  • Nullables 0.0.2
  • OffsetArrays 0.4.2
  • PaddedViews 0.2.0
  • RangeArrays 0.2.0
  • Ratios 0.2.0
  • Reexport 0.1.0
  • Requires 0.4.3
  • Rotations 0.6.1
  • SHA 0.5.2
  • SIUnits 0.1.0
  • ShowItLikeYouBuildIt 0.2.0
  • SimpleTraits 0.5.1
  • SortingAlgorithms 0.2.0
  • SpecialFunctions 0.3.6
  • StaticArrays 0.6.6
  • StatsBase 0.19.4
  • StringDistances 0.2.0
  • TexExtensions 0.1.0
  • TiledIteration 0.1.0
  • Tokenize 0.4.2
  • URIParser 0.3.0
  • WebSockets 0.4.0
  • WinRPM 0.3.1
  • WoodburyMatrices 0.2.2
  • ZMQ 0.5.1

I’ve encountered the following problem with Atom (1.23.2 x 64) after doing a Pkg.update(). When I launch Atom I get the error:

INFO: Precompiling module Atom.
ERROR: LoadError: LoadError:
Unable to load

lib (C:\Users\szpakz.julia\v0.6\HttpParser\deps\usr\lib\libhttp_parser64.DLL)

Please re-run Pkg.build(package), and restart Julia.
Stacktrace:
[1]
include_from_node1 at .\loading.jl:576
[2] include at .\sysimg.jl:14
[3] include_from_node1 at .\loading.jl:576
[4] include at .\sysimg.jl:14
while loading C:\Users\szpakz.julia\v0.6\HttpParser\src…\deps\deps.jl, in expression starting on line 12
while loading C:\Users\szpakz.julia\v0.6\HttpParser\src\HttpParser.jl, in expression starting on line 9
ERROR: LoadError: LoadError:
Failed to precompile HttpParser to C:\Users\szpakz.julia\lib\v0.6\HttpParser.ji.
Stacktrace:
[1] compilecache(::String) at .\loading.jl:710
[2] _require(::Symbol) at .\loading.jl:463
[3] require(::Symbol) at .\loading.jl:405
[4] include at .\sysimg.jl:14
[5] include_from_node1 at .\loading.jl:576
[6] include at .\sysimg.jl:14
while loading C:\Users\szpakz.julia\v0.6\HttpServer\src\RequestParser.jl, in expression starting on line 16
while loading C:\Users\szpakz.julia\v0.6\HttpServer\src\HttpServer.jl, in expression starting on line 12
ERROR: LoadError: LoadError:
Failed to precompile HttpServer to C:\Users\szpakz.julia\lib\v0.6\HttpServer.ji.
Stacktrace:
[1] compilecache(::String) at .\loading.jl:710
[2] _require(::Symbol) at .\loading.jl:463
[3] require(::Symbol) at .\loading.jl:405
[4] include_from_node1 at .\loading.jl:576
[5] include at .\sysimg.jl:14
[6] include_from_node1 at .\loading.jl:576
[7] include at .\sysimg.jl:14
while loading C:\Users\szpakz.julia\v0.6\Mux\src\server.jl, in expression starting on line 1
while loading C:\Users\szpakz.julia\v0.6\Mux\src\Mux.jl, in expression starting on line 24
ERROR: LoadError: LoadError:
Failed to precompile Mux to C:\Users\szpakz.julia\lib\v0.6\Mux.ji.
Stacktrace:
[1] compilecache(::String) at .\loading.jl:710
[2] _require(::Symbol) at .\loading.jl:463
[3] require(::Symbol) at .\loading.jl:405
[4] include_from_node1 at .\loading.jl:576
[5] include at .\sysimg.jl:14
[6] include_from_node1 at .\loading.jl:576
[7] include at .\sysimg.jl:14
while loading C:\Users\szpakz.julia\v0.6\Blink\src\content/content.jl, in expression starting on line 1
while loading C:\Users\szpakz.julia\v0.6\Blink\src\Blink.jl, in expression starting on line 9
ERROR: LoadError:
Failed to precompile Blink to C:\Users\szpakz.julia\lib\v0.6\Blink.ji.
Stacktrace:
[1] compilecache(::String) at .\loading.jl:710
[2] _require(::Symbol) at .\loading.jl:463
[3] require(::Symbol) at .\loading.jl:405
[4] include_from_node1 at .\loading.jl:576
[5] include at .\sysimg.jl:14
while loading C:\Users\szpakz.julia\v0.6\Atom\src\Atom.jl, in expression starting on line 5
ERROR: LoadError:
Failed to precompile Atom to C:\Users\szpakz.julia\lib\v0.6\Atom.ji.
Stacktrace:

[1]
compilecache at .\loading.jl:710
[2] _require at .\loading.jl:497
[3] require at .\loading.jl:405
[4] include_from_node1 at .\loading.jl:576
[5] include at .\sysimg.jl:14
[6] process_options at .\client.jl:305
[7] _start at .\client.jl:371
while loading C:\Users\szpakz.atom\packages\julia-client\script\boot.jl, in expression starting on line 34

Upon running Pkg.build("HttpParser") the following messages appear in Atom.

WARNING: Module Compat with uuid 743600597957855 is missing from the cache.
This may mean module Compat does not support precompilation but is imported by a module that does.
ERROR: LoadError:
Declaring precompile(false) is not allowed in files that are being precompiled.
Stacktrace:
[1]
_require at .\loading.jl:455
[2] require at .\loading.jl:405
[3] include_from_node1 at .\loading.jl:576
[4] include at .\sysimg.jl:14
while loading C:\Users\szpakz.julia\v0.6\Blink\src\Blink.jl, in expression starting on line 6
ERROR: LoadError:
Failed to precompile Blink to C:\Users\szpakz.julia\lib\v0.6\Blink.ji.
Stacktrace:
[1] compilecache(::String) at .\loading.jl:710
[2] _require(::Symbol) at .\loading.jl:463
[3] require(::Symbol) at .\loading.jl:405
[4] include_from_node1 at .\loading.jl:576
[5] include at .\sysimg.jl:14
while loading C:\Users\szpakz.julia\v0.6\Atom\src\Atom.jl, in expression starting on line 5

I’ve searched this forum and found this post, which produces different errors upon building HttpParser. The Juno IDE asks that I post the error to discourse.

Many thanks for your time and any advice you might have to resolve the problem.


#2

Running Pkg.build("Blink") solved the problem for me.