Download packages error on Julia 1.1.1

Hello, I am working on setting up Julia on a new computer that is running Catalina.

A few versions of Julia are currently installed, but I’m having trouble setting up / downloading packages. I’ve never seen error like this before, on my older computers. I tried searching forums but I’m not coming up with anything. I could use some guidance.

Here are the errors on 1.1.1

_

_ _ _ (_) _ | Documentation: https://docs.julialang.org

(_) | (_) (_) |

_ _ | | __ _ | Type “?” for help, “]?” for Pkg help.

| | | | | | |/ _` | |

| | || | | | (| | | Version 1.1.1 (2019-05-16)

/ |_|||_’_| | Official https://julialang.org/ release

|__/ |
julia> import Pkg

julia> Pkg.status()

Status ~/.julia/environments/v1.1/Project.toml

(empty environment)

julia> Pkg.add(“MAT”)

Cloning default registries into ~/.julia

Cloning registry from “https://github.com/JuliaRegistries/General.git

ERROR: SystemError: opening file “/Users/User/.julia/registries/General/Registry.toml”: No such file or directory

Stacktrace:

[1] #systemerror#43( ::Nothing, ::Function, ::String, ::Bool ) at ./error.jl:134

[2] systemerror at ./error.jl:134 [inlined]

[3] #open#309( ::Bool, ::Nothing, ::Nothing, ::Nothing, ::Nothing, ::Function, ::String ) at ./iostream.jl:289

[4] #open at ./none:0 [inlined]

[5] open( ::String, ::String ) at ./iostream.jl:345

[6] #open#310( ::Base.Iterators.Pairs{Union{},Union{},Tuple{},NamedTuple{(),Tuple{}}}, ::Function, ::typeof(Pkg.TOML.parse), ::String, ::Vararg{String,N} where N ) at ./iostream.jl:373

[7] open at ./iostream.jl:373 [inlined]

[8] parsefile at /Users/julia/buildbot/worker/package_macos64/build/usr/share/julia/stdlib/v1.1/Pkg/ext/TOML/src/TOML.jl:46 [inlined]

[9] #read_registry#91( ::Bool, ::Function, ::String ) at /Users/julia/buildbot/worker/package_macos64/build/usr/share/julia/stdlib/v1.1/Pkg/src/Types.jl:1149

[10] read_registry at /Users/julia/buildbot/worker/package_macos64/build/usr/share/julia/stdlib/v1.1/Pkg/src/Types.jl:1144 [inlined]

[11] clone_or_cp_registries( ::Pkg.Types.Context, ::Array{Pkg.Types.RegistrySpec,1}, ::String ) at /Users/julia/buildbot/worker/package_macos64/build/usr/share/julia/stdlib/v1.1/Pkg/src/Types.jl:1121

[12] clone_or_cp_registries at /Users/julia/buildbot/worker/package_macos64/build/usr/share/julia/stdlib/v1.1/Pkg/src/Types.jl:1087 [inlined]

[13] clone_default_registries() at /Users/julia/buildbot/worker/package_macos64/build/usr/share/julia/stdlib/v1.1/Pkg/src/Types.jl:1037

[14] find_registered!( ::Pkg.Types.EnvCache, ::Array{String,1}, ::Array{Base.UUID,1} ) at /Users/julia/buildbot/worker/package_macos64/build/usr/share/julia/stdlib/v1.1/Pkg/src/Types.jl:1312

[15] registry_resolve!( ::Pkg.Types.EnvCache, ::Array{Pkg.Types.PackageSpec,1} ) at /Users/julia/buildbot/worker/package_macos64/build/usr/share/julia/stdlib/v1.1/Pkg/src/Types.jl:949

[16] #add_or_develop#17( ::Symbol, ::Bool, ::Base.Iterators.Pairs{Union{},Union{},Tuple{},NamedTuple{(),Tuple{}}}, ::Function, ::Pkg.Types.Context, ::Array{Pkg.Types.PackageSpec,1} ) at /Users/julia/buildbot/worker/package_macos64/build/usr/share/julia/stdlib/v1.1/Pkg/src/API.jl:52

[17] #add_or_develop at ./none:0 [inlined]

[18] #add_or_develop#16 at /Users/julia/buildbot/worker/package_macos64/build/usr/share/julia/stdlib/v1.1/Pkg/src/API.jl:36 [inlined]

[19] #add_or_develop at ./none:0 [inlined]

[20] #add_or_develop#13 at /Users/julia/buildbot/worker/package_macos64/build/usr/share/julia/stdlib/v1.1/Pkg/src/API.jl:34 [inlined]

[21] #add_or_develop at ./none:0 [inlined]

[22] #add_or_develop#12( ::Base.Iterators.Pairs{Symbol,Symbol,Tuple{Symbol},NamedTuple{(:mode,),Tuple{Symbol}}}, ::Function, ::String ) at /Users/julia/buildbot/worker/package_macos64/build/usr/share/julia/stdlib/v1.1/Pkg/src/API.jl:33

[23] #add_or_develop at ./none:0 [inlined]

[24] #add#22 at /Users/julia/buildbot/worker/package_macos64/build/usr/share/julia/stdlib/v1.1/Pkg/src/API.jl:64 [inlined]

[25] add( ::String ) at /Users/julia/buildbot/worker/package_macos64/build/usr/share/julia/stdlib/v1.1/Pkg/src/API.jl:64

[26] top-level scope at none:0

Was this after you tried to download 0.4.7? My guess is that downloading 0.4.7 messed up your .julia in some way that made downloading 1.1 not work.

As people will mention in the other thread, you shouldn’t download 0.4.7. It’s unsupported and old, very old.

The 1.1.1 errors disappeared after I let 1.5 install the packages instead.

In general, is there a reason why you are installing every version julia? Not that installing so many versions shouldn’t work, but it shouldn’t really matter that much. Just stay on the latest stable release and you will be fine.

For supporting legacy code.

Fair enough. But in general it should be the case that you can just install the LTS and then make whatever minimal adjustment you need to make code developed for any 1.x work.

It’s a nice idea in theory but not one worth litigating here. Fact is I need it working.